summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-04-14 18:16:32 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-14 18:17:58 +0200
commitb31b0155ea2421821cd9293702cbb2d196943dd2 (patch)
tree6f3d1ffd41ace676604e9aa1cc2469960a93b225
parent4e644ab8a6b67d1e9db459c31d8f23ee14276140 (diff)
downloadpatches-b31b0155ea2421821cd9293702cbb2d196943dd2.tar
patches-b31b0155ea2421821cd9293702cbb2d196943dd2.tar.gz
build: Download aarch64 bootstrap binaries from alpha.gnu.org.
* build-aux/download.scm (file-name->uri): Remove flashner.co.il URL. * gnu/packages/package-management.scm (boot-guile-uri): Likewise.
-rw-r--r--build-aux/download.scm20
-rw-r--r--gnu/packages/package-management.scm5
2 files changed, 11 insertions, 14 deletions
diff --git a/build-aux/download.scm b/build-aux/download.scm
index 0e98bef55b..8dfa914603 100644
--- a/build-aux/download.scm
+++ b/build-aux/download.scm
@@ -42,17 +42,15 @@
(match (string-tokenize file (char-set-complement (char-set #\/)))
((_ ... system basename)
(string->uri
- (match system
- ("aarch64-linux"
- (string-append "http://flashner.co.il/guix/bootstrap/aarch64-linux"
- "/20170217/" basename))
- (_ (string-append %url-base "/" system
- (match system
- ("armhf-linux"
- "/20150101/")
- (_
- "/20131110/"))
- basename)))))))
+ (string-append %url-base "/" system
+ (match system
+ ("aarch64-linux"
+ "/20170217/")
+ ("armhf-linux"
+ "/20150101/")
+ (_
+ "/20131110/"))
+ basename)))))
(match (command-line)
((_ file expected-hash)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 2760d4d2fb..82132d587a 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -61,9 +61,8 @@
arch "-linux"
"/20150101/guile-2.0.11.tar.xz"))
((string=? "aarch64" arch)
- (let ((suffix "/bootstrap/aarch64-linux/20170217/guile-2.0.14.tar.xz"))
- (list (string-append "http://alpha.gnu.org/gnu/guix" suffix)
- (string-append "http://flashner.co.il/guix" suffix))))
+ (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
+ arch "-linux/20170217/guile-2.0.14.tar.xz"))
(else
(string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
arch "-linux"