summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-05-17 17:55:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-05-18 18:25:26 +0200
commitab67f84bbe89dd096ec6fb28c12e79654ea091d1 (patch)
tree5ddae5ca614686fc9e52129f11a994cea5ccb05e
parent70e33ec795b42a497df342950469f65c8406988c (diff)
downloadpatches-ab67f84bbe89dd096ec6fb28c12e79654ea091d1.tar
patches-ab67f84bbe89dd096ec6fb28c12e79654ea091d1.tar.gz
gnu: godot: Enable release build.
* gnu/packages/game-development.scm (godot)[arguments]: Set release_debug target in #:scons-flags to enable optimized build. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/game-development.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 26aa4f714b..dfa55b136f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1585,7 +1585,7 @@ games.")
(build-system scons-build-system)
(arguments
`(#:scons ,scons-python2
- #:scons-flags (list "platform=x11"
+ #:scons-flags (list "platform=x11" "target=release_debug"
,@(if (string-prefix? "aarch64" (or (%current-target-system)
(%current-system)))
`("CCFLAGS=-DNO_THREADS")