summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 11:02:03 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:51:10 +0100
commita4880a27356f55db5959918ef7982b48e8ecb837 (patch)
tree3062afc6ac64757af7ffd11ccf8c032a9855fe45
parent39a7b7206545bd1ccedeccc9ff71ca787baf19a5 (diff)
downloadpatches-a4880a27356f55db5959918ef7982b48e8ecb837.tar
patches-a4880a27356f55db5959918ef7982b48e8ecb837.tar.gz
gnu: microscheme: Don't use unstable tarball.
* gnu/packages/avr.scm (microscheme)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/avr.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index a84b43da6a..eaa3c7d046 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,6 +24,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
@@ -138,18 +140,19 @@ C++.")
(package
(name "microscheme")
(version "0.9.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ryansuchocki/"
- "microscheme/archive/v" version ".tar.gz"))
- (sha256
- (base32
- "1n404mh7z2icy3ga1mx249lk9x091k7idj6xpcf20hnmzabd0k0x"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ryansuchocki/microscheme.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1r3ng4pw1s9yy1h5rafra1rq19d3vmb5pzbpcz1913wz22qdd976"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:parallel-build? #f ; fails to build otherwise
- #:tests? #f ; no tests
+ `(#:parallel-build? #f ; fails to build otherwise
+ #:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
(delete 'configure))