summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-01-17 10:20:59 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-20 22:06:25 +1000
commita132f7d68f4c61133c0c97d8e5125c48f7205ac9 (patch)
tree6150c9d9562ebd3002688c60bcd3e8d82d686e48
parente88d5fa9ebab07d0b23cb3fc0f3f38bd41047e94 (diff)
downloadpatches-a132f7d68f4c61133c0c97d8e5125c48f7205ac9.tar
patches-a132f7d68f4c61133c0c97d8e5125c48f7205ac9.tar.gz
tests: Move beatify-description tests to import-tests.
Fixes <http://bugs.gnu.org/22391>. * tests/cran.scm (beautify-description: use double spacing, beautify-description: transform fragment into sentence). Move from here ... * tests/import-utils.scm: ... to here. New file. * Makefile.am (SCM_TESTS): Add import-utils.
-rw-r--r--Makefile.am3
-rw-r--r--tests/cran.scm10
-rw-r--r--tests/import-utils.scm39
3 files changed, 41 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 74bc8b5948..7e41990cac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -241,7 +241,8 @@ SCM_TESTS = \
tests/cve.scm \
tests/file-systems.scm \
tests/services.scm \
- tests/containers.scm
+ tests/containers.scm \
+ tests/import-utils.scm
if HAVE_GUILE_JSON
diff --git a/tests/cran.scm b/tests/cran.scm
index e4f22353bd..83d2e7f554 100644
--- a/tests/cran.scm
+++ b/tests/cran.scm
@@ -86,16 +86,6 @@ Date/Publication: 2015-07-14 14:15:16
'()
((@@ (guix import cran) listify) simple-alist "BadList"))
-(test-equal "beautify-description: use double spacing"
- "This is a package. It is great. Trust me Mr. Hendrix."
- ((@@ (guix import cran) beautify-description)
- "This is a package. It is great. Trust me Mr. Hendrix."))
-
-(test-equal "beautify-description: transform fragment into sentence"
- "This package provides a function to establish world peace"
- ((@@ (guix import cran) beautify-description)
- "A function to establish world peace"))
-
(test-assert "description->package"
;; Replace network resources with sample data.
(mock ((guix build download) url-fetch
diff --git a/tests/import-utils.scm b/tests/import-utils.scm
new file mode 100644
index 0000000000..08365816d4
--- /dev/null
+++ b/tests/import-utils.scm
@@ -0,0 +1,39 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-import-utils)
+ #:use-module (guix tests)
+ #:use-module (guix import utils)
+ #:use-module (srfi srfi-64))
+
+(test-begin "import-utils")
+
+(test-equal "beautify-description: use double spacing"
+ "This is a package. It is great. Trust me Mr. Hendrix."
+ (beautify-description
+ "This is a package. It is great. Trust me Mr. Hendrix."))
+
+(test-equal "beautify-description: transform fragment into sentence"
+ "This package provides a function to establish world peace"
+ (beautify-description "A function to establish world peace"))
+
+(test-end "import-utils")
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))