summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-31 21:11:21 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-31 22:39:48 +0200
commit97c15a297da3ecefcd0d4af902158cef239ff3b9 (patch)
tree8eab4ee6ac0534f51bf247a093ca7e2a5b038bc8
parent98b87b82bef87c7794365e26832bbd1afb013721 (diff)
downloadpatches-97c15a297da3ecefcd0d4af902158cef239ff3b9.tar
patches-97c15a297da3ecefcd0d4af902158cef239ff3b9.tar.gz
gnu: tcsh: Add alternate URL for old tarballs.
Reported by Alexander Vorobiev <alexander.vorobiev@gmail.com>. * gnu/packages/tcsh.scm (tcsh)[source]: Add alternate URL.
-rw-r--r--gnu/packages/tcsh.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/tcsh.scm b/gnu/packages/tcsh.scm
index 814f2a6321..0bd1b92b8f 100644
--- a/gnu/packages/tcsh.scm
+++ b/gnu/packages/tcsh.scm
@@ -31,13 +31,17 @@
(name "tcsh")
(version "6.18.01")
(source (origin
- (method url-fetch)
- (uri (string-append "ftp://ftp.astron.com/pub/tcsh/tcsh-"
- version ".tar.gz"))
- (sha256
- (base32 "1a4z9kwgx1iqqzvv64si34m60gj34p7lp6rrcrb59s7ka5wa476q"))
- (patches (list (search-patch "tcsh-fix-autotest.patch")))
- (patch-flags '("-p0"))))
+ (method url-fetch)
+ ;; Old tarballs are moved to old/.
+ (uri (list (string-append "ftp://ftp.astron.com/pub/tcsh/"
+ "tcsh-" version ".tar.gz")
+ (string-append "ftp://ftp.astron.com/pub/tcsh/"
+ "old/tcsh-" version ".tar.gz")))
+ (sha256
+ (base32
+ "1a4z9kwgx1iqqzvv64si34m60gj34p7lp6rrcrb59s7ka5wa476q"))
+ (patches (list (search-patch "tcsh-fix-autotest.patch")))
+ (patch-flags '("-p0"))))
(build-system gnu-build-system)
(inputs
`(("autoconf" ,autoconf)