summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-28 21:40:13 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-04 20:10:34 +0100
commit936aa05209402dd399869ffae188db5dd5f67d69 (patch)
tree281017ffb73bf324c0921f8efe836fcbc2d68eba
parent208e743415d7c36e9684851a31cc30dec16db2c3 (diff)
downloadpatches-936aa05209402dd399869ffae188db5dd5f67d69.tar
patches-936aa05209402dd399869ffae188db5dd5f67d69.tar.gz
gnu: Remove duplicate nlohmann-json-cpp package.
* gnu/packages/serialization.scm (nlohmann-json-cpp): Move variable ... * gnu/packages/cpp.scm (nlohmann-json-cpp): ... here. Mark as deprecated by JSON-MODERN-CXX. * gnu/packages/jupyter.scm (xeus)[inputs]: Change NLOHMANN-JSON-CPP to JSON-MODERN-CXX. * gnu/packages/video.scm (mkvtoolnix)[inputs]: Likewise.
-rw-r--r--gnu/packages/cpp.scm3
-rw-r--r--gnu/packages/jupyter.scm3
-rw-r--r--gnu/packages/serialization.scm35
-rw-r--r--gnu/packages/video.scm2
4 files changed, 6 insertions, 37 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index b35b1b8e26..335f9a65cd 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -253,6 +253,9 @@ as ordering relation.")
intuitive syntax and trivial integration.")
(license license:expat)))
+(define-public nlohmann-json-cpp
+ (deprecated-package "nlohmann-json-cpp" json-modern-cxx))
+
(define-public xtl
(package
(name "xtl")
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index fbb4367ea5..e65a8bd6c9 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -30,7 +30,6 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
- #:use-module (gnu packages serialization)
#:use-module (gnu packages time)
#:use-module (gnu packages tls))
@@ -168,7 +167,7 @@ Messaging Protocol}.")
("python-jupyter-client" ,python-jupyter-client)))
(inputs
`(("xtl" ,xtl)
- ("nlohmann-json-cpp" ,nlohmann-json-cpp)
+ ("json-modern-cxx" ,json-modern-cxx)
("cppzmq" ,cppzmq)
("zeromq" ,zeromq)
("openssl" ,openssl)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index a213e4ba0c..8efad0af86 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -40,6 +40,7 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
#:use-module (gnu packages gcc)
@@ -378,40 +379,6 @@ convert JSON documents to BSON and the opposite. BSON stands for Binary JSON,
it is comparable to protobuf.")
(license license:asl2.0)))
-(define-public nlohmann-json-cpp
- (package
- (name "nlohmann-json-cpp")
- (version "3.7.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/nlohmann/json.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0v7xih4zjixxxfvkfbs7a8j9qcvpwlsv4vrkbyns3hc7b44nb8ap"))))
- (build-system cmake-build-system)
- (native-inputs
- ;; Integer overflow tests like those from
- ;; <https://github.com/nlohmann/json/issues/1447> fail when building with
- ;; gcc@5. Thus, build with a newer GCC.
- `(("gcc" ,gcc-9)))
- (arguments
- '(#:phases (modify-phases %standard-phases
- (add-before 'build 'unset-path-variables
- (lambda _
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPLUS_INCLUDE_PATH")
- #t)))))
- (home-page "https://nlohmann.github.io/json/")
- (synopsis "JSON library for C++")
- (description
- "JSON library for C++ trying to accomplish “Intuitive syntax”,
-“Trivial integration”, and “Serious testing”.
-However, “Memory efficiency” and “Speed” have not been primary goals.")
- (license license:expat)))
-
(define-public python-ruamel.yaml
(package
(name "python-ruamel.yaml")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 030280c624..7b56d8e460 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -428,7 +428,7 @@ H.264 (MPEG-4 AVC) video streams.")
("gettext" ,gettext-minimal)
("googletest" ,googletest)
("libxslt" ,libxslt)
- ("nlohmann-json-cpp" ,nlohmann-json-cpp)
+ ("json-modern-cxx" ,json-modern-cxx)
("perl" ,perl)
("pkg-config" ,pkg-config)
("po4a" ,po4a)