summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Peters <holger.peters@posteo.de>2020-05-20 09:07:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-05-20 09:33:04 +0200
commit90f44ee4967c6d387e82abf88fd2c39d94415daf (patch)
treea26b0cb9793dc700c9ce5be2c2d26d4af270d58e
parent8bfc0512da448007ae7c0688802d4dc8bf27fa61 (diff)
downloadpatches-90f44ee4967c6d387e82abf88fd2c39d94415daf.tar
patches-90f44ee4967c6d387e82abf88fd2c39d94415daf.tar.gz
gnu: Add python-pyramid.
* gnu/packages/python-web.scm (python-pyramid): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 604c59c083..05fd1599a1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3975,3 +3975,32 @@ according to the standard set by PasteDeploy ")
imported Python files in sys.modules as well as custom paths. When files are
changed the process is restarted.")
(license license:expat)))
+
+(define-public python-pyramid
+ (package
+ (name "python-pyramid")
+ (version "1.10.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyramid" version))
+ (sha256
+ (base32
+ "0rkxs1ajycg2zh1c94xlmls56mx5m161sn8112skj0amza6cn36q"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-hupper" ,python-hupper)
+ ("python-plaster-pastedeploy" ,python-plaster-pastedeploy)
+ ("python-translationstring" ,python-translationstring)
+ ("python-venusian" ,python-venusian)
+ ("python-webob" ,python-webob)
+ ("python-zope-deprecation" ,python-zope-deprecation)
+ ("python-zope-interface" ,python-zope-interface)
+ ("python-webtest" ,python-webtest)
+ ("python-zope-component" ,python-zope-component)
+ ("python-plaster" ,python-plaster)))
+ (home-page "https://trypyramid.com/")
+ (synopsis "Python web-framework suitable for small and large sites")
+ (description
+ "Pyramid makes it easy to write web applications. From minimal
+request/response web apps to larger, grown applications.")
+ (license license:repoze)))