summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2017-06-25 23:08:16 +0800
committer宋文武 <iyzsong@member.fsf.org>2017-06-26 00:12:23 +0800
commit8fc7bd234cc2ef1a6f5f1bc907162e4feb025233 (patch)
treeeb9082bbc060a2c256a3b737be3a40e0d23a0dd6
parent6876a6fe53a63b986a1e061e07c4c378a9da95c9 (diff)
downloadpatches-8fc7bd234cc2ef1a6f5f1bc907162e4feb025233.tar
patches-8fc7bd234cc2ef1a6f5f1bc907162e4feb025233.tar.gz
gnu: libvirt: Update to 3.4.0, add more inputs.
* gnu/packages/qemu.scm (libvirt): Update to 3.4.0. [inputs]: Add dmidecode, dnsmasq, ebtables, iproute and iptables.
-rw-r--r--gnu/packages/qemu.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index 8e04f20e0c..f77fbf0be1 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages disk)
+ #:use-module (gnu packages dns)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -268,14 +269,14 @@ all common programming languages. Vala bindings are also provided.")
(define-public libvirt
(package
(name "libvirt")
- (version "3.2.0")
+ (version "3.4.0")
(source (origin
(method url-fetch)
(uri (string-append "http://libvirt.org/sources/libvirt-"
version ".tar.xz"))
(sha256
(base32
- "17i08v3836c9w4dwcklvbgzin3aw1gbksm9ry8kpk837nn1s10cl"))))
+ "13945hrijybfh634c4x9cbkfazvpzajgv55ll2nx412r4bv6l622"))))
(build-system gnu-build-system)
(arguments
`(;; FAIL: virshtest
@@ -324,7 +325,12 @@ all common programming languages. Vala bindings are also provided.")
("perl" ,perl)
("python" ,python-2)
("libyajl" ,libyajl)
- ("audit" ,audit)))
+ ("audit" ,audit)
+ ("dmidecode" ,dmidecode)
+ ("dnsmasq" ,dnsmasq)
+ ("ebtables" ,ebtables)
+ ("iproute" ,iproute)
+ ("iptables" ,iptables)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "http://libvirt.org")