summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-12 14:28:36 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-12 14:28:36 +0100
commit84dfb4582121480cec7a8cfb73725ef006b747b5 (patch)
tree7e4df514240aee3b88590e5ac13c1df8f30ec350
parent0ecc3bf3092ad5e18e3ef18822b2ba8c1a8813cf (diff)
downloadpatches-84dfb4582121480cec7a8cfb73725ef006b747b5.tar
patches-84dfb4582121480cec7a8cfb73725ef006b747b5.tar.gz
gnu: Introduce (gnu artwork) module.
* gnu/artwork.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it. * gnu/services/xorg.scm: Use it. (%artwork-repository): Remove. * gnu/system/grub.scm: Use it. (%artwork-repository): Remove.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/artwork.scm40
-rw-r--r--gnu/services/xorg.scm13
-rw-r--r--gnu/system/grub.scm12
4 files changed, 43 insertions, 23 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 98041e02fa..e6cb2ef73f 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -23,6 +23,7 @@
GNU_SYSTEM_MODULES = \
gnu.scm \
+ gnu/artwork.scm \
gnu/packages.scm \
gnu/packages/abiword.scm \
gnu/packages/acct.scm \
diff --git a/gnu/artwork.scm b/gnu/artwork.scm
new file mode 100644
index 0000000000..cf405d1258
--- /dev/null
+++ b/gnu/artwork.scm
@@ -0,0 +1,40 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu artwork)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:export (%artwork-repository))
+
+;;; Commentary:
+;;;
+;;; Common place for the definition of the Guix artwork repository.
+;;;
+;;; Code:
+
+(define %artwork-repository
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.savannah.gnu.org/guix/guix-artwork.git")
+ (commit "71d77b1")))
+ (sha256
+ (base32
+ "03j0fwh6j5knzbfjj3cs0a30cssy706p18b8x7d1p91p29hlzjif"))))
+
+;;; artwork.scm ends here
diff --git a/gnu/services/xorg.scm b/gnu/services/xorg.scm
index 1f00d80042..9c075acd0f 100644
--- a/gnu/services/xorg.scm
+++ b/gnu/services/xorg.scm
@@ -17,8 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu services xorg)
- #:use-module (guix packages)
- #:use-module (guix git-download)
+ #:use-module (gnu artwork)
#:use-module (gnu services)
#:use-module (gnu system linux) ; 'pam-service'
#:use-module ((gnu packages base) #:select (canonical-package))
@@ -162,16 +161,6 @@ EndSection
;;; SLiM log-in manager.
;;;
-(define %artwork-repository
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://git.savannah.gnu.org/guix/guix-artwork.git")
- (commit "71d77b1")))
- (sha256
- (base32
- "03j0fwh6j5knzbfjj3cs0a30cssy706p18b8x7d1p91p29hlzjif"))))
-
(define %default-slim-theme
;; Theme based on work by Felipe López.
#~(string-append #$%artwork-repository "/slim"))
diff --git a/gnu/system/grub.scm b/gnu/system/grub.scm
index dad39bfdc7..00e09f9736 100644
--- a/gnu/system/grub.scm
+++ b/gnu/system/grub.scm
@@ -24,7 +24,7 @@
#:use-module (guix monads)
#:use-module (guix gexp)
#:use-module (guix download)
- #:use-module (guix git-download)
+ #:use-module (gnu artwork)
#:autoload (gnu packages grub) (grub)
#:autoload (gnu packages inkscape) (inkscape)
#:autoload (gnu packages imagemagick) (imagemagick)
@@ -77,16 +77,6 @@
(color-highlight grub-theme-color-highlight
(default '((fg . white) (bg . blue)))))
-(define %artwork-repository
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://git.savannah.gnu.org/guix/guix-artwork.git")
- (commit "281157a")))
- (sha256
- (base32
- "02x1myh013mzqnr28d4k1mxs4malv5vszpxdwkjarbhbbkchypz5"))))
-
(define %background-image
(grub-image
(aspect-ratio 4/3)