summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-06 12:02:22 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-06 12:12:51 +0100
commit81ffe6377385a3035d75cf9c8a1b61f32796c2ad (patch)
tree44a63f3f1154193b3e27594619d468938eec1d9a
parent2b155e3abca485290c602d48973fdb9fe887751e (diff)
downloadpatches-81ffe6377385a3035d75cf9c8a1b61f32796c2ad.tar
patches-81ffe6377385a3035d75cf9c8a1b61f32796c2ad.tar.gz
gnu: cpio: Update to 2.13 [fixes CVE-2015-1197, CVE-2019-14866].
* gnu/packages/cpio.scm (cpio): Update to 2.13. Remove "cpio-CVE-2016-2037.patch". * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/cpio.scm5
-rw-r--r--gnu/packages/patches/cpio-CVE-2016-2037.patch49
3 files changed, 2 insertions, 53 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index ec3974a8aa..2513b4003c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -760,7 +760,6 @@ dist_patch_DATA = \
%D%/packages/patches/coda-use-system-libs.patch \
%D%/packages/patches/combinatorial-blas-awpm.patch \
%D%/packages/patches/combinatorial-blas-io-fix.patch \
- %D%/packages/patches/cpio-CVE-2016-2037.patch \
%D%/packages/patches/cpufrequtils-fix-aclocal.patch \
%D%/packages/patches/crawl-upgrade-saves.patch \
%D%/packages/patches/crda-optional-gcrypt.patch \
diff --git a/gnu/packages/cpio.scm b/gnu/packages/cpio.scm
index 77a0c82d2e..58b2f45937 100644
--- a/gnu/packages/cpio.scm
+++ b/gnu/packages/cpio.scm
@@ -28,15 +28,14 @@
(define-public cpio
(package
(name "cpio")
- (version "2.12")
+ (version "2.13")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/cpio/cpio-"
version ".tar.bz2"))
(sha256
(base32
- "0vi9q475h1rki53100zml75vxsykzyhrn70hidy41s5c2rc8r6bh"))
- (patches (search-patches "cpio-CVE-2016-2037.patch"))))
+ "0vbgnhkawdllgnkdn6zn1f56fczwk0518krakz2qbwhxmv2vvdga"))))
(build-system gnu-build-system)
(home-page "https://www.gnu.org/software/cpio/")
(synopsis "Manage cpio and tar file archives")
diff --git a/gnu/packages/patches/cpio-CVE-2016-2037.patch b/gnu/packages/patches/cpio-CVE-2016-2037.patch
deleted file mode 100644
index f1e068fb45..0000000000
--- a/gnu/packages/patches/cpio-CVE-2016-2037.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-Fix CVE-2016-2037 (out of bounds write in process_copy_in()).
-
-Copied from upstream mailing list:
-https://lists.gnu.org/archive/html/bug-cpio/2016-01/msg00005.html
-
----
-
- Other calls to cpio_safer_name_suffix seem to be safe.
- .
- * src/copyin.c (process_copy_in): Make sure that file_hdr.c_name
- has at least two bytes allocated.
- * src/util.c (cpio_safer_name_suffix): Document that use of this
- function requires to be careful.
-Author: Pavel Raiskup <praiskup@redhat.com>
-
----
- src/copyin.c | 2 ++
- src/util.c | 5 ++++-
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
-Index: cpio-2.11+dfsg/src/copyin.c
-===================================================================
---- cpio-2.11+dfsg.orig/src/copyin.c
-+++ cpio-2.11+dfsg/src/copyin.c
-@@ -1433,6 +1433,8 @@ process_copy_in ()
- break;
- }
-
-+ if (file_hdr.c_namesize <= 1)
-+ file_hdr.c_name = xrealloc(file_hdr.c_name, 2);
- cpio_safer_name_suffix (file_hdr.c_name, false, !no_abs_paths_flag,
- false);
-
-Index: cpio-2.11+dfsg/src/util.c
-===================================================================
---- cpio-2.11+dfsg.orig/src/util.c
-+++ cpio-2.11+dfsg/src/util.c
-@@ -1374,7 +1374,10 @@ set_file_times (int fd,
- }
-
- /* Do we have to ignore absolute paths, and if so, does the filename
-- have an absolute path? */
-+ have an absolute path?
-+ Before calling this function make sure that the allocated NAME buffer has
-+ capacity at least 2 bytes to allow us to store the "." string inside. */
-+
- void
- cpio_safer_name_suffix (char *name, bool link_target, bool absolute_names,
- bool strip_leading_dots)