summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2016-06-09 21:53:02 +0300
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2016-06-10 17:40:27 +0300
commit7c6058c08266f663973d1b7eb729e36e24728d17 (patch)
tree890ab122f4ba80e07e663f3025648367c3e9e0f2
parentc59f62e9cb02893dbae78acc5f0ac12df7b45432 (diff)
downloadpatches-7c6058c08266f663973d1b7eb729e36e24728d17.tar
patches-7c6058c08266f663973d1b7eb729e36e24728d17.tar.gz
gnu: higan: Various improvements.
* gnu/packages/games.scm (higan): Use semi-official repository at GitLab (using hotfix tag 098b which is equivalent to official release 098). Add a patch to remove the build flag -march=native. Set profile to balanced. * gnu/packages/patches/higan-remove-march-native-flag.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/games.scm9
-rw-r--r--gnu/packages/patches/higan-remove-march-native-flag.patch13
3 files changed, 20 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 8915c46cdd..f31e5776d9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -542,6 +542,7 @@ dist_patch_DATA = \
%D%/packages/patches/gtk3-respect-GUIX_GTK3_PATH.patch \
%D%/packages/patches/gtkglext-disable-disable-deprecated.patch \
%D%/packages/patches/hdf5-config-date.patch \
+ %D%/packages/patches/higan-remove-march-native-flag.patch \
%D%/packages/patches/hop-bigloo-4.0b.patch \
%D%/packages/patches/hop-linker-flags.patch \
%D%/packages/patches/hydra-automake-1.15.patch \
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0d095ac368..1d0a945347 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2247,15 +2247,17 @@ Red Eclipse provides fast paced and accessible gameplay.")
(define-public higan
(package
(name "higan")
- (version "098")
+ (version "098b")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://github.com/TaylanUB/higan/archive/v" version ".tar.gz"))
+ "https://gitlab.com/higan/higan/repository/archive.tar.gz?ref=v"
+ version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "12snxrk8wa94x3l69qcimgm0xc22zjgf7vzhckp2lzyfbf27950v"))))
+ (base32 "05j0xzr01gsyia4gj6jmdzklll4iky1kwxgxw0mmfcgm10m0h3bf"))
+ (patches (search-patches "higan-remove-march-native-flag.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -2321,6 +2323,7 @@ Red Eclipse provides fast paced and accessible gameplay.")
`("PATH" ":" prefix (,bin))))))))
#:make-flags
(list "compiler=g++"
+ "profile=balanced" ;default is accuracy; which is quite slow
(string-append "prefix=" (assoc-ref %outputs "out")))
;; There is no test suite.
#:tests? #f))
diff --git a/gnu/packages/patches/higan-remove-march-native-flag.patch b/gnu/packages/patches/higan-remove-march-native-flag.patch
new file mode 100644
index 0000000000..8f4a36dc35
--- /dev/null
+++ b/gnu/packages/patches/higan-remove-march-native-flag.patch
@@ -0,0 +1,13 @@
+Remove -march=native from build flags.
+
+--- a/higan/GNUmakefile
++++ b/higan/GNUmakefile
+@@ -32,7 +32,7 @@ ifeq ($(platform),windows)
+ else ifeq ($(platform),macosx)
+ flags += -march=native
+ else ifneq ($(filter $(platform),linux bsd),)
+- flags += -march=native -fopenmp
++ flags += -fopenmp
+ link += -fopenmp
+ link += -Wl,-export-dynamic
+ link += -lX11 -lXext