summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-07-16 12:14:13 +0300
committerAlex Kost <alezost@gmail.com>2015-07-18 13:05:01 +0300
commit7c125ce02384cff462a3ed84ac77153921e1c2a5 (patch)
tree665f7ee9f7e11b50490f62acefaceab3fc533992
parent01bec8a61d537d9f432aeb17cc299c3976f85656 (diff)
downloadpatches-7c125ce02384cff462a3ed84ac77153921e1c2a5.tar
patches-7c125ce02384cff462a3ed84ac77153921e1c2a5.tar.gz
gnu packages: Avoid description lines with leading "(".
* gnu/packages/curl.scm (curl): Reformat description to avoid a line beginning with "(" because such lines break font-lock highlighting in Emacs. * gnu/packages/flashing-tools.scm (dfu-programmer): Likewise. * gnu/packages/games.scm (gnugo): Likewise. * gnu/packages/gnome.scm (json-glib): Likewise. * gnu/packages/image.scm (jbig2dec): Likewise. * gnu/packages/maths.scm (units): Likewise. * gnu/packages/pdf.scm (mupdf): Likewise. * gnu/packages/web.scm (perl-encode-locale): Likewise. * gnu/packages/wordnet.scm (wordnet): Likewise. * gnu/packages/xml.scm (libxml2):Likewise.
-rw-r--r--gnu/packages/curl.scm10
-rw-r--r--gnu/packages/flashing-tools.scm5
-rw-r--r--gnu/packages/games.scm15
-rw-r--r--gnu/packages/gnome.scm11
-rw-r--r--gnu/packages/image.scm8
-rw-r--r--gnu/packages/maths.scm8
-rw-r--r--gnu/packages/pdf.scm4
-rw-r--r--gnu/packages/web.scm14
-rw-r--r--gnu/packages/wordnet.scm6
-rw-r--r--gnu/packages/xml.scm4
10 files changed, 44 insertions, 41 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index f5cb503f8d..201bdf8443 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -102,10 +102,10 @@
"curl is a command line tool for transferring data with URL syntax,
supporting DICT, FILE, FTP, FTPS, Gopher, HTTP, HTTPS, IMAP, IMAPS, LDAP,
LDAPS, POP3, POP3S, RTMP, RTSP, SCP, SFTP, SMTP, SMTPS, Telnet and TFTP.
-curl supports SSL certificates, HTTP POST, HTTP PUT, FTP uploading,
-HTTP form based upload, proxies, cookies, user+password authentication
-(Basic, Digest, NTLM, Negotiate, kerberos...), file transfer resume,
-proxy tunneling, and so on")
+curl supports SSL certificates, HTTP POST, HTTP PUT, FTP uploading, HTTP
+form based upload, proxies, cookies, file transfer resume, user+password
+authentication (Basic, Digest, NTLM, Negotiate, kerberos...), proxy
+tunneling, and so on.")
(license (license:non-copyleft "file://COPYING"
- "See COPYING in the distribution."))
+ "See COPYING in the distribution."))
(home-page "http://curl.haxx.se/")))
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 648430ad5a..dafe20422c 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -124,6 +124,7 @@ technique (ISP).")
(home-page "http://dfu-programmer.github.io/")
(synopsis "Device firmware update programmer for Atmel chips")
(description
- "Dfu-programmer is a multi-platform command-line programmer for Atmel
-(8051, AVR, XMEGA & AVR32) chips with a USB bootloader supporting ISP")
+ "Dfu-programmer is a multi-platform command-line programmer for
+Atmel (8051, AVR, XMEGA & AVR32) chips with a USB bootloader supporting
+ISP.")
(license gpl2+)))
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8f495f7b32..0db555d4c6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -853,13 +853,14 @@ multi-system game/emulator system.")
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
(synopsis "Play the game of Go")
- (description "GNU Go is a program that plays the game of Go, in which
-players place stones on a grid to form territory or capture other stones.
-While it can be played directly from the terminal, rendered in ASCII
-characters, it is also possible to play GNU Go with 3rd party graphical
-interfaces or even in Emacs. It supports the standard game storage format
-(SGF, Smart Game Format) and inter-process communication format (GMP, Go
-Modem Protocol).")
+ (description
+ "GNU Go is a program that plays the game of Go, in which players
+place stones on a grid to form territory or capture other stones. While
+it can be played directly from the terminal, rendered in ASCII characters,
+it is also possible to play GNU Go with 3rd party graphical interfaces or
+even in Emacs. It supports the standard game storage format (SGF, Smart
+Game Format) and inter-process communication format (GMP, Go Modem
+Protocol).")
(home-page "http://www.gnu.org/software/gnugo/")
(license license:gpl3+)))
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0ae7c252ad..c3a6c5dc9a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1778,11 +1778,12 @@ configuration storage systems.")
`(("glib" ,glib))) ;according to json-glib-1.0.pc
(home-page "https://wiki.gnome.org/Projects/JsonGlib")
(synopsis "Compiler for the GObject type system")
- (description "JSON-GLib is a C library based on GLib providing
-serialization and deserialization support for the JavaScript Object Notation
-(JSON) format described by RFC 4627. It provides parser and generator
-GObject classes and various wrappers for the complex data types employed by
-JSON, such as arrays and objects.")
+ (description
+ "JSON-GLib is a C library based on GLib providing serialization and
+deserialization support for the JavaScript Object Notation (JSON) format
+described by RFC 4627. It provides parser and generator GObject classes and
+various wrappers for the complex data types employed by JSON, such as arrays
+and objects.")
(license license:lgpl2.1+)))
(define-public libxklavier
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 30f380038b..84f03967a7 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -264,10 +264,10 @@ arithmetic ops.")
(build-system gnu-build-system)
(synopsis "Decoder of the JBIG2 image compression format")
(description
- "JBIG2 is designed for lossy or lossless encoding of 'bilevel'
-(1-bit monochrome) images at moderately high resolution, and in
-particular scanned paper documents. In this domain it is very
-efficient, offering compression ratios on the order of 100:1.
+ "JBIG2 is designed for lossy or lossless encoding of 'bilevel' (1-bit
+monochrome) images at moderately high resolution, and in particular scanned
+paper documents. In this domain it is very efficient, offering compression
+ratios on the order of 100:1.
This is a decoder only implementation, and currently is in the alpha
stage, meaning it doesn't completely work yet. However, it is
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7eb2f5aeae..2d651cb22a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -90,10 +90,10 @@
(synopsis "Conversion between thousands of scales")
(description
"GNU Units converts numeric quantities between units of measure. It
-can handle scale changes through adaptive usage of standard scale prefixes
-(micro-, kilo-, etc.). It can also handle nonlinear conversions such as
-Fahrenheit to Celsius. Its interpreter is powerful enough to be used
-effectively as a scientific calculator.")
+can handle scale changes through adaptive usage of standard scale
+prefixes (micro-, kilo-, etc.). It can also handle nonlinear
+conversions such as Fahrenheit to Celsius. Its interpreter is powerful
+enough to be used effectively as a scientific calculator.")
(license license:gpl3+)
(home-page "http://www.gnu.org/software/units/")))
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 541281332d..3a426dc293 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -424,8 +424,8 @@ but also provides support for other operations such as searching and
listing the table of contents and hyperlinks.
The library ships with a rudimentary X11 viewer, and a set of command
-line tools for batch rendering (pdfdraw), examining the file structure
-(pdfshow), and rewriting files (pdfclean).")
+line tools for batch rendering (pdfdraw), rewriting files (pdfclean),
+and examining the file structure (pdfshow).")
(license license:agpl3+)))
(define-public qpdf
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 99a176f9d5..a1d263ceb0 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1566,13 +1566,13 @@ for files and urls.")
(synopsis "Perl locale encoding determination")
(description
"The POSIX locale system is used to specify both the language
-conventions requested by the user and the preferred character set to consume
-and output. The Encode::Locale module looks up the charset and encoding
-(called a CODESET in the locale jargon) and arranges for the Encode module
-to know this encoding under the name \"locale\". It means bytes obtained
-from the environment can be converted to Unicode strings by calling
-Encode::encode(locale => $bytes) and converted back again with
-Encode::decode(locale => $string).")
+conventions requested by the user and the preferred character set to
+consume and output. The Encode::Locale module looks up the charset and
+encoding (called a CODESET in the locale jargon) and arranges for the
+Encode module to know this encoding under the name \"locale\". It means
+bytes obtained from the environment can be converted to Unicode strings
+by calling Encode::encode(locale => $bytes) and converted back again
+with Encode::decode(locale => $string).")
(home-page "http://search.cpan.org/~gaas/Encode-Locale/")))
(define-public perl-file-listing
diff --git a/gnu/packages/wordnet.scm b/gnu/packages/wordnet.scm
index 58831c4259..1823a624ed 100644
--- a/gnu/packages/wordnet.scm
+++ b/gnu/packages/wordnet.scm
@@ -79,9 +79,9 @@
(synopsis "Lexical database for the English language")
(description
"WordNet® is a large lexical database of English. Nouns, verbs,
-adjectives and adverbs are grouped into sets of cognitive synonyms
-(synsets), each expressing a distinct concept. Synsets are interlinked by
-means of conceptual-semantic and lexical relations. The resulting network of
+adjectives and adverbs are grouped into sets of cognitive synonyms (synsets),
+each expressing a distinct concept. Synsets are interlinked by means of
+conceptual-semantic and lexical relations. The resulting network of
meaningfully related words and concepts can be navigated with the browser.
WordNet is also freely and publicly available for download. WordNet's
structure makes it a useful tool for computational linguistics and natural
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 0fc51c5501..66d6d63a3f 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -84,8 +84,8 @@ things the parser might find in the XML document (like start tags).")
(file-type 'regular))))
(search-paths native-search-paths)
(description
- "Libxml2 is the XML C parser and toolkit developed for the Gnome project
-(but it is usable outside of the Gnome platform).")
+ "Libxml2 is the XML C parser and toolkit developed for the Gnome
+project (but it is usable outside of the Gnome platform).")
(license license:x11)))
(define-public python-libxml2