summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-15 15:26:20 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-15 17:20:57 +0100
commit5c798ca71dcd009896654da7d6a1f8942c6f3c50 (patch)
treec86cc60b0d265d723daa8535370f5df26623cedc
parent4403030b7de2485dbeb6ee54c56551a2bd2b5244 (diff)
downloadpatches-5c798ca71dcd009896654da7d6a1f8942c6f3c50.tar
patches-5c798ca71dcd009896654da7d6a1f8942c6f3c50.tar.gz
gnu: python: Update to 3.6.4.
* gnu/packages/patches/python-3-search-paths.patch: Adjust context. * gnu/packages/python.scm (python): Update to 3.6.4. [source]: Re-enable test_socket.py.
-rw-r--r--gnu/packages/patches/python-3-search-paths.patch13
-rw-r--r--gnu/packages/python.scm10
2 files changed, 8 insertions, 15 deletions
diff --git a/gnu/packages/patches/python-3-search-paths.patch b/gnu/packages/patches/python-3-search-paths.patch
index 7feddb8e30..73e3f4ccf5 100644
--- a/gnu/packages/patches/python-3-search-paths.patch
+++ b/gnu/packages/patches/python-3-search-paths.patch
@@ -3,17 +3,14 @@ looking for headers and libraries.
--- setup.py 2015-10-07 23:32:58.891329173 +0200
+++ setup.py 2015-10-07 23:46:29.653349924 +0200
-@@ -507,11 +507,8 @@ class PyBuildExt(build_ext):
+@@ -575,8 +575,8 @@
# if a file is found in one of those directories, it can
# be assumed that no additional -I,-L directives are needed.
if not cross_compiling:
-- lib_dirs = self.compiler.library_dirs + [
-- '/lib64', '/usr/lib64',
-- '/lib', '/usr/lib',
-- ]
-- inc_dirs = self.compiler.include_dirs + ['/usr/include']
+- lib_dirs = self.compiler.library_dirs + system_lib_dirs
+- inc_dirs = self.compiler.include_dirs + system_include_dirs
+ lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
+ inc_dirs = os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
else:
- lib_dirs = self.compiler.library_dirs[:]
- inc_dirs = self.compiler.include_dirs[:]
+ # Add the sysroot paths. 'sysroot' is a compiler option used to
+ # set the logical path of the standard system headers and
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dbb5ccb52e..82639939fd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -338,7 +338,7 @@ data types.")
(define-public python-3.6
(package (inherit python-2)
- (version "3.6.3")
+ (version "3.6.4")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
@@ -351,17 +351,13 @@ data types.")
(patch-flags '("-p0"))
(sha256
(base32
- "1nl1raaagr4car787a2hmjv2dw6gqny53xfd6wisbgx4r5kxk9yd"))
+ "1fna7g8jxzl4kd2pqmmqhva5724c5m920x3fsrpsgskaylmr76qm"))
(snippet
'(begin
(for-each delete-file
'("Lib/ctypes/test/test_structures.py" ; fails on aarch64
"Lib/ctypes/test/test_win32.py" ; fails on aarch64
- "Lib/test/test_fcntl.py" ; fails on aarch64
- ;; This test fails on kernels older than 4.5.
- ;; It is skipped on these kernels in later
- ;; versions of Python.
- "Lib/test/test_socket.py"))
+ "Lib/test/test_fcntl.py")) ; fails on aarch64
#t))))
(arguments
(substitute-keyword-arguments (package-arguments python-2)