summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-07 11:01:37 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-05-08 16:00:00 +0200
commit4c88ae7b0331a7d671321a345eacc2bdb7595ee5 (patch)
tree652b483fb199e8c62d52c2faa7c5cab0647dce10
parenta54f373e6ec940e08b3fc95f2b5938429001976d (diff)
downloadpatches-4c88ae7b0331a7d671321a345eacc2bdb7595ee5.tar
patches-4c88ae7b0331a7d671321a345eacc2bdb7595ee5.tar.gz
gnu: Add gphotofs.
* gnu/packages/file-systems.scm (gphotofs): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/file-systems.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index ce1155c755..d8953016e5 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -48,6 +48,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages nfs)
#:use-module (gnu packages onc-rpc)
+ #:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages readline)
@@ -56,6 +57,33 @@
#:use-module (gnu packages valgrind)
#:use-module (gnu packages xml))
+(define-public gphotofs
+ (package
+ (name "gphotofs")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "mirror://sourceforge/gphoto/gphotofs/" version
+ "/gphotofs-0.5.tar.gz"))
+ (sha256
+ (base32
+ "04slwhr6ap9xcc27wphk22ad8yn79ngyy5z10lxams3k5liahvc2"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("fuse" ,fuse)
+ ("glib" ,glib)
+ ("libgphoto2" ,libgphoto2)))
+ (synopsis "Virtual filesystem for libgphoto2 using FUSE")
+ (description "GPhotoFS is a FUSE filesystem module to mount your camera as
+a filesystem on Linux. This allow using your camera with any tool able to read
+from a mounted filesystem.")
+ (home-page "http://www.gphoto.org/proj/gphotofs/")
+ (license license:gpl2+)))
+
(define-public bcachefs-tools
(let ((commit "ab2f1ec24f5307b0cf1e3c4ad19bf350d9f54d9f")
(revision "0"))