summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-05-19 15:31:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-05-20 12:42:12 +0200
commit42d41d86f38958ebcff370b0e56da5c69165943c (patch)
treee712998121d720b4d2b73d12fb06bcd4b6575064
parent90f44ee4967c6d387e82abf88fd2c39d94415daf (diff)
downloadpatches-42d41d86f38958ebcff370b0e56da5c69165943c.tar
patches-42d41d86f38958ebcff370b0e56da5c69165943c.tar.gz
gnu: Add emacs-vcsh.
* gnu/packages/emacs-xyz.scm (emacs-vcsh): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 69786f335b..d952e8ea6c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14919,6 +14919,29 @@ repository, @code{magit-org-todos} will create a section in your Magit status
buffer with each of your todos.")
(license license:gpl3+))))
+(define-public emacs-vcsh
+ (package
+ (name "emacs-vcsh")
+ (version "0.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/stepnem/vcsh-el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "183pffdiqb7qqmjq31wxl3fpv8qswqgg99gb716rddiyk15ysri7"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/stepnem/vcsh-el")
+ (synopsis "Emacs VCSH integration")
+ (description
+ "This library provides basic ``enter'' functionality and a few
+convenience commands to initialize a @acronym{VCSH, Version Control System for
+$HOME} repository and add files to it. It can be used in conjunction with
+Magit.")
+ (license license:public-domain)))
+
(define-public emacs-f3
(package
(name "emacs-f3")