summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-02 09:16:19 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-21 20:07:51 +0100
commit4207da9e2cea91d67b7d1c93efb7f316e802a391 (patch)
treee8372223e2af70d33629252090d44207bb9b2030
parentc109d3268bc0fc732141b1e60368c00e41ae4638 (diff)
downloadpatches-4207da9e2cea91d67b7d1c93efb7f316e802a391.tar
patches-4207da9e2cea91d67b7d1c93efb7f316e802a391.tar.gz
gnu: Add purpose.
* gnu/packages/kde-frameworks.scm(purpose): New variable.
-rw-r--r--gnu/packages/kde-frameworks.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 82bd2c4ea2..9230bb71c0 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3495,6 +3495,45 @@ script engines.")
;; dual licensed
(license (list license:gpl2+ license:lgpl2.1+))))
+(define-public purpose
+ (package
+ (name "purpose")
+ (version "5.63.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1mc5z131z9da6qjhlxqz64ys4fgq38iryna58f8l04x8f9igjn8f"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(;;TODO: ("kaccounts" ,kaccounts)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("knotifications" ,knotifications)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kirigami" ,kirigami)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (arguments
+ `(#:tests? #f ;; seem to require network; don't find QTQuick components
+ #:configure-flags '("-DBUILD_TESTING=OFF"))) ; not run anyway
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Offers available actions for a specific purpose")
+ (description "This framework offers the possibility to create integrate
+services and actions on any application without having to implement them
+specifically. Purpose will offer them mechanisms to list the different
+alternatives to execute given the requested action type and will facilitate
+components so that all the plugins can receive all the information they
+need.")
+ (license license:lgpl2.1+)))
+
;; This version of kdbusaddons does not use kinit as an input, and is used to
;; build kinit-bootstrap, as well as bootstrap versions of all kinit
;; dependencies which also rely on kdbusaddons.