summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-04-30 18:19:11 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-05-16 17:54:38 +0200
commit3c102716d0926602330d3cf616ec9dd0640b7c81 (patch)
tree39793b17eb9d68a18f0156ce2541fe69b8ea834d
parent8ba990e69dcf471c3c24964cd8d7438c7fae427c (diff)
downloadpatches-3c102716d0926602330d3cf616ec9dd0640b7c81.tar
patches-3c102716d0926602330d3cf616ec9dd0640b7c81.tar.gz
gnu: Add font-api-mj-mincho.
* gnu/packages/fonts.scm (font-api-mj-mincho): New variable.
-rw-r--r--gnu/packages/fonts.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 64d5c17346..f4071f456f 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
+;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1737,3 +1738,35 @@ variation Arial. Tamil characters are inherently vertically-elliptical. The
orthography of Roman glyphs of Meera Inimai are also based on this
characteristic so that they sit smoothly with the Tamil glyphs.")
(license license:silofl1.1)))
+
+(define-public font-ipa-mj-mincho
+ (package
+ (name "font-ipa-mj-mincho")
+ (version "006.01")
+ (source (origin
+ (method url-fetch/zipbomb)
+ (uri (string-append "https://mojikiban.ipa.go.jp/OSCDL/IPAmjMincho"
+ "/ipamjm" (string-join (string-split version #\.) "")
+ ".zip"))
+ (sha256
+ (base32
+ "0s2vs9p7vd7ajnn6c2icli069sjwi4d45a39fczqpwwn507lwj9m"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((doc-dir (string-append (assoc-ref outputs "out")
+ "/share/doc/font-ipa-mj-mincho")))
+ (mkdir-p doc-dir)
+ (copy-file "Readme.txt" (string-append doc-dir "/README"))
+ (copy-file "IPA_Font_License_Agreement_v1.0.txt"
+ (string-append doc-dir "/LICENSE"))
+ #t))))))
+ (home-page "https://mojikiban.ipa.go.jp/1300.html")
+ (synopsis "Japanese font from the Information-technology Promotion Agency")
+ (description "MJM Mincho is a font that aims at, for example, allowing you
+to write people's name, or for formal business situations where it is necessary
+to have a detailed and proper character style.")
+ (license license:ipa)))