summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-09-09 21:00:11 +0800
committer宋文武 <iyzsong@gmail.com>2015-09-09 21:06:30 +0800
commit363ccf9fe2e67606edc2ecf0ca70824e7adc1ce0 (patch)
tree27e1e4459b8f06214f8d41ca9554f093e92bc1cc
parentc940a145594d3d1a93b30ec3260751debe1c63bb (diff)
downloadpatches-363ccf9fe2e67606edc2ecf0ca70824e7adc1ce0.tar
patches-363ccf9fe2e67606edc2ecf0ca70824e7adc1ce0.tar.gz
gnu: xfce4-settings: Set the default icon theme to "gnome".
Fixes <http://bugs.gnu.org/21217>. * gnu/packages/patches/xfce4-settings-defaults.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xfce.scm (xfce4-settings)[source]: Add patch.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/xfce4-settings-defaults.patch29
-rw-r--r--gnu/packages/xfce.scm4
3 files changed, 33 insertions, 1 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 4acbb51aad..e6f751f772 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -707,6 +707,7 @@ dist_patch_DATA = \
gnu/packages/patches/xf86-video-trident-remove-mibstore.patch \
gnu/packages/patches/xf86-video-vmware-glibc-2.20.patch \
gnu/packages/patches/xfce4-panel-plugins.patch \
+ gnu/packages/patches/xfce4-settings-defaults.patch \
gnu/packages/patches/xmodmap-asprintf.patch \
gnu/packages/patches/zathura-plugindir-environment-variable.patch
diff --git a/gnu/packages/patches/xfce4-settings-defaults.patch b/gnu/packages/patches/xfce4-settings-defaults.patch
new file mode 100644
index 0000000000..fe91ae5f70
--- /dev/null
+++ b/gnu/packages/patches/xfce4-settings-defaults.patch
@@ -0,0 +1,29 @@
+This patch make Xfce use "gnome" as the default icon theme and enable font antialias.
+
+Taken from ArchLinux.
+
+diff -upr xfce4-settings-4.12.0.orig/xfsettingsd/xsettings.xml xfce4-settings-4.12.0/xfsettingsd/xsettings.xml
+--- xfce4-settings-4.12.0.orig/xfsettingsd/xsettings.xml 2015-02-24 03:33:11.000000000 +0200
++++ xfce4-settings-4.12.0/xfsettingsd/xsettings.xml 2015-03-01 09:52:24.376869688 +0200
+@@ -6,8 +6,8 @@
+ <?xml version="1.0" encoding="UTF-8"?>
+ <channel name="xsettings" version="1.0">
+ <property name="Net" type="empty">
+ <property name="ThemeName" type="empty"/>
+- <property name="IconThemeName" type="empty"/>
++ <property name="IconThemeName" type="string" value="gnome"/>
+ <property name="DoubleClickTime" type="int" value="400"/>
+ <property name="DoubleClickDistance" type="int" value="5"/>
+ <property name="DndDragThreshold" type="int" value="8"/>
+@@ -19,9 +19,9 @@
+ </property>
+ <property name="Xft" type="empty">
+ <property name="DPI" type="empty"/>
+- <property name="Antialias" type="int" value="-1"/>
++ <property name="Antialias" type="int" value="1"/>
+ <property name="Hinting" type="int" value="-1"/>
+- <property name="HintStyle" type="string" value="hintnone"/>
++ <property name="HintStyle" type="string" value="hintfull"/>
+ <property name="RGBA" type="string" value="none"/>
+ <!-- <property name="Lcdfilter" type="string" value="none"/> -->
+ </property>
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index a9ceb5bdd8..e42c58050d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -452,7 +452,9 @@ allows you to shutdown the computer from Xfce.")
"/src/" name "-" version ".tar.bz2"))
(sha256
(base32
- "108za1cmjslwzkdl76x9kwxkq8z734kg9nz8rxk057f10pqwxgh4"))))
+ "108za1cmjslwzkdl76x9kwxkq8z734kg9nz8rxk057f10pqwxgh4"))
+ (patches
+ (list (search-patch "xfce4-settings-defaults.patch")))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)