summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-05-08 15:42:08 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-08 16:30:50 +0200
commit2bb5b1d400b00cb1d577ddb22ea100e1c56dbe01 (patch)
tree6ff791010d4511ca08d69d99b699a98a4070c990
parent7ee215dea9226518911774f35130323d602a8ba9 (diff)
downloadpatches-2bb5b1d400b00cb1d577ddb22ea100e1c56dbe01.tar
patches-2bb5b1d400b00cb1d577ddb22ea100e1c56dbe01.tar.gz
gnu: gcc: Add 10.1.0.
* gnu/packages/gcc.scm (gcc-10): New variable.
-rw-r--r--gnu/packages/gcc.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 3d1ae25dc9..1155e3debb 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
@@ -537,6 +537,20 @@ It also includes runtime support libraries for these languages.")))
"gcc-9-asan-fix-limits-include.patch"
"gcc-5.0-libvtv-runpath.patch"))))))
+(define-public gcc-10
+ (package
+ (inherit gcc-8)
+ (version "10.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gcc/gcc-"
+ version "/gcc-" version ".tar.xz"))
+ (sha256
+ (base32
+ "18kyds3ss4j7in8shlsbmjafdhin400mq739d0dnyrabhhiqm2dn"))
+ (patches (search-patches "gcc-9-strmov-store-file-names.patch"
+ "gcc-5.0-libvtv-runpath.patch"))))))
+
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions and the gfortran definition
;; accordingly.