summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-29 19:13:49 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-30 17:06:42 +0200
commit25280065814aecd7ce56baf4866b0c05acf8028b (patch)
tree6c7bc32aff322623031b99a3ca54e8cbbc90de8b
parent1b0668272cb44d78a94b65ae0e004903b78e4138 (diff)
downloadpatches-25280065814aecd7ce56baf4866b0c05acf8028b.tar
patches-25280065814aecd7ce56baf4866b0c05acf8028b.tar.gz
build-system/meson: Do not inherit the 'bootstrap' phase.
* guix/build/meson-build-system.scm (%standard-phases): Remove 'bootstrap'. * gnu/packages/glib.scm (glib)[arguments]: Adjust accordingly.
-rw-r--r--gnu/packages/glib.scm1
-rw-r--r--guix/build/meson-build-system.scm1
2 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 62543fe114..eae8297531 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -200,7 +200,6 @@ shared NFS home directories.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (delete 'bootstrap)
(add-before 'build 'pre-build
(lambda* (#:key inputs outputs #:allow-other-keys)
;; For tests/gdatetime.c.
diff --git a/guix/build/meson-build-system.scm b/guix/build/meson-build-system.scm
index d0975fcab0..8043a84abb 100644
--- a/guix/build/meson-build-system.scm
+++ b/guix/build/meson-build-system.scm
@@ -108,6 +108,7 @@ for example libraries only needed for the tests."
;; from the gnu-build-system. If the glib-or-gtk? key is #f (the default)
;; then the extra phases will be removed again in (guix build-system meson).
(modify-phases glib-or-gtk:%standard-phases
+ (delete 'bootstrap)
(replace 'configure configure)
(replace 'build build)
(replace 'check check)