summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-08 19:03:12 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-08 21:56:05 +0100
commit02fef9619bd96086aa9255ffb0944d4cda617c84 (patch)
treedb576a11ab1a7f3379271a059d31996bf3c809af
parent9d2c24d22780f6db8b2190905dcff6c8d498df56 (diff)
downloadpatches-02fef9619bd96086aa9255ffb0944d4cda617c84.tar
patches-02fef9619bd96086aa9255ffb0944d4cda617c84.tar.gz
gnu: Boost: Update to 1.72.0.
* gnu/packages/patches/boost-dumpversion.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/boost.scm (boost): Update to 1.72.0. [source](uri): Remove defunct mirror. [source](patches): Remove. [arguments]: Adjust /bin/sh substitutions. Remove obsolete workaround.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/boost.scm25
-rw-r--r--gnu/packages/patches/boost-dumpversion.patch24
3 files changed, 8 insertions, 42 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e2b605e0b8..2a60a8d4c7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -750,7 +750,6 @@ dist_patch_DATA = \
%D%/packages/patches/binutils-loongson-workaround.patch \
%D%/packages/patches/blender-2.79-newer-ffmpeg.patch \
%D%/packages/patches/blender-2.79-python-3.7-fix.patch \
- %D%/packages/patches/boost-dumpversion.patch \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/calibre-no-updates-dialog.patch \
%D%/packages/patches/calibre-remove-test-bs4.patch \
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 3665dccb56..1f896d3811 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,21 +47,17 @@
(define-public boost
(package
(name "boost")
- (version "1.70.0")
+ (version "1.72.0")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
(string-map (lambda (x) (if (eq? x #\.) #\_ x)) version)))
- (list (string-append "mirror://sourceforge/boost/boost/" version
- "/boost_" version-with-underscores ".tar.bz2")
- (string-append "https://dl.bintray.com/boostorg/release/"
- version "/source/boost_"
- version-with-underscores ".tar.bz2"))))
- (patches
- (search-patches "boost-dumpversion.patch"))
+ (string-append "https://dl.bintray.com/boostorg/release/"
+ version "/source/boost_"
+ version-with-underscores ".tar.bz2")))
(sha256
(base32
- "0y47nc7w0arwgj4x1phadxbvl7wyfcgknbz5kv8lzpl98wsyh2j3"))))
+ "08h7cv61fd0lzb4z50xanfqn0pdgvizjrpd1kcdgj725pisb5jar"))))
(build-system gnu-build-system)
(inputs `(("icu4c" ,icu4c)
("zlib" ,zlib)))
@@ -75,11 +72,6 @@
#:make-flags
(list "threading=multi" "link=shared"
- ;; XXX: Disable installation of Boosts modular CMake config scripts
- ;; which conflicts in 1.70.0 with the ones provided by CMake.
- ;; See <https://bugs.gnu.org/36721>.
- "--no-cmake-config"
-
;; Set the RUNPATH to $libdir so that the libs find each other.
(string-append "linkflags=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib")
@@ -109,9 +101,8 @@
(out (assoc-ref outputs "out")))
(substitute* '("libs/config/configure"
"libs/spirit/classic/phoenix/test/runtest.sh"
- "tools/build/src/engine/execunix.c"
- "tools/build/src/engine/Jambase"
- "tools/build/src/engine/jambase.c")
+ "tools/build/src/engine/execunix.cpp"
+ "tools/build/src/engine/Jambase")
(("/bin/sh") (which "sh")))
(setenv "SHELL" (which "sh"))
diff --git a/gnu/packages/patches/boost-dumpversion.patch b/gnu/packages/patches/boost-dumpversion.patch
deleted file mode 100644
index 7df779cfe6..0000000000
--- a/gnu/packages/patches/boost-dumpversion.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-This issue is described here: https://github.com/openwrt/packages/pull/8685
-and has not been solved as of 1.70.0 release.
-
---- a/tools/build/src/tools/common.jam
-+++ b/tools/build/src/tools/common.jam
-@@ -973,18 +973,6 @@
- }
- }
-
-- # From GCC 5, versioning changes and minor becomes patch
-- if $(tag) = gcc && [ numbers.less 4 $(version[1]) ]
-- {
-- version = $(version[1]) ;
-- }
--
-- # Ditto, from Clang 4
-- if ( $(tag) = clang || $(tag) = clangw ) && [ numbers.less 3 $(version[1]) ]
-- {
-- version = $(version[1]) ;
-- }
--
- # On intel, version is not added, because it does not matter and it is the
- # version of vc used as backend that matters. Ideally, we should encode the
- # backend version but that would break compatibility with V1.