summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-28 14:01:46 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-28 20:19:28 +0100
commit01307bba9c00ada07f8a39bd8de7031beef12afd (patch)
tree5b077642f24ae2daeb22bc8c4f22936ca5c2abf2
parent6da31b3c7bfcd8f012695574e91d7da32f202280 (diff)
downloadpatches-01307bba9c00ada07f8a39bd8de7031beef12afd.tar
patches-01307bba9c00ada07f8a39bd8de7031beef12afd.tar.gz
gnu: reptyr: Update to 0.7.0.
* gnu/packages/screen.scm (reptyr): Update to 0.7.0. [source]: Remove patch. [arguments]: Add bash completion directory name. * gnu/packages/patches/reptyr-fix-gcc-7.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/reptyr-fix-gcc-7.patch38
-rw-r--r--gnu/packages/screen.scm22
3 files changed, 12 insertions, 49 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 42d8f1ce18..833944bfbd 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1218,7 +1218,6 @@ dist_patch_DATA = \
%D%/packages/patches/readline-6.2-CVE-2014-2524.patch \
%D%/packages/patches/red-eclipse-remove-gamma-name-hack.patch \
%D%/packages/patches/reposurgeon-add-missing-docbook-files.patch \
- %D%/packages/patches/reptyr-fix-gcc-7.patch \
%D%/packages/patches/ripperx-missing-file.patch \
%D%/packages/patches/rpcbind-CVE-2017-8779.patch \
%D%/packages/patches/rtags-separate-rct.patch \
diff --git a/gnu/packages/patches/reptyr-fix-gcc-7.patch b/gnu/packages/patches/reptyr-fix-gcc-7.patch
deleted file mode 100644
index 5e0e581218..0000000000
--- a/gnu/packages/patches/reptyr-fix-gcc-7.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-This patch allows reptyr to build with gcc 7. It is taken from reptyr mainline patches
-fa0d63f and b45fd92.
-
-https://github.com/nelhage/reptyr/commit/fa0d63ff8c488be15976e5353580b565e85586a1
-https://github.com/nelhage/reptyr/commit/b45fd9238958fcf2d8f3d6fc23e6d491febea2ac
-
-Patch by Nelson Elhage <nelhage@nelhage.com>.
-
-diff --git a/attach.c b/attach.c
-index bd8ef8c..8d9cbf8 100644
---- a/attach.c
-+++ b/attach.c
-@@ -389,8 +389,11 @@ int setup_steal_socket(struct steal_pty_state *steal) {
- return errno;
-
- steal->addr_un.sun_family = AF_UNIX;
-- snprintf(steal->addr_un.sun_path, sizeof(steal->addr_un.sun_path),
-- "%s/reptyr.sock", steal->tmpdir);
-+ if (snprintf(steal->addr_un.sun_path, sizeof(steal->addr_un.sun_path),
-+ "%s/reptyr.sock", steal->tmpdir) >= sizeof(steal->addr_un.sun_path)) {
-+ error("tmpdir path too long!");
-+ return ENAMETOOLONG;
-+ }
-
- if ((steal->sockfd = socket(AF_UNIX, SOCK_DGRAM, 0)) < 0)
- return errno;
-diff --git a/platform/linux/linux.h b/platform/linux/linux.h
-index 9e6b78a..3ec5a99 100644
---- a/platform/linux/linux.h
-+++ b/platform/linux/linux.h
-@@ -40,6 +40,7 @@
- #include <sys/ptrace.h>
- #include <asm/ptrace.h>
- #include <sys/types.h>
-+#include <sys/sysmacros.h>
- #include <sys/user.h>
- #include <unistd.h>
- #include <stdlib.h>
diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index 38df2594f2..eb4c477a89 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -153,23 +153,25 @@ window manager as well as the Tmux terminal multiplexer.")
(define-public reptyr
(package
(name "reptyr")
- (version "0.6.2")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/nelhage/reptyr/archive"
"/reptyr-" version ".tar.gz"))
- ;; XXX: To be removed on next reptyr release.
- (patches (search-patches "reptyr-fix-gcc-7.patch"))
(sha256
- (base32
- "07pfl0rkgm8m3f3jy8r9l2yvnhf8lgllpsk3mh57mhzdxq8fagf7"))))
+ (base32 "10s9blv8xljzfdn4xly5y2q66kd0ldj3wnflymsxb5g6r3s3kidi"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no tests
- #:make-flags (list "CC=gcc"
- (string-append "PREFIX=" %output))
- #:phases (modify-phases %standard-phases (delete 'configure))))
+ '(#:tests? #f ; no tests
+ #:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "BASHCOMPDIR=" (assoc-ref %outputs "out")
+ "/etc/bash_completion.d"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
(home-page "https://github.com/nelhage/reptyr")
(synopsis "Tool for reparenting a running program to a new terminal")
(description