summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 13:30:45 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:43 -0500
commitb4e26067d649b0efcc3b7d00d5dbe599e395da13 (patch)
tree5e5454df9a7ec2f3fb50b9ce98140691602d0347
parent6cd84b98dcad77de0bd647a0b56b65453ce318a9 (diff)
downloadpatches-b4e26067d649b0efcc3b7d00d5dbe599e395da13.tar
patches-b4e26067d649b0efcc3b7d00d5dbe599e395da13.tar.gz
gnu: ghc-tree-diff: Update to 0.1.
* gnu/packages/haskell-xyz.scm (ghc-tree-diff): Update to 0.1. [arguments]: Remove '#:cabal-revision' and '#:phases'. [inputs]: Remove 'ghc-generics-sop' and 'ghc-memotrie'; add 'ghc-bytestring-builder'.
-rw-r--r--gnu/packages/haskell-xyz.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 4c592ff4a2..cf0df9a616 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10934,7 +10934,7 @@ but also need those types.")
(define-public ghc-tree-diff
(package
(name "ghc-tree-diff")
- (version "0.0.1")
+ (version "0.1")
(source
(origin
(method url-fetch)
@@ -10944,26 +10944,15 @@ but also need those types.")
".tar.gz"))
(sha256
(base32
- "049v44c520jy3icxlnrvbdblh3mjmvd7m6qmkzxbzkf02x63xqmz"))))
+ "1156nbqn0pn9lp4zjsy4vv5g5wmy4zxwmbqdgvq349rydynh3ng3"))))
(build-system haskell-build-system)
- (arguments
- `(#:cabal-revision
- ("4" "1rqxxyj6hqllahs11693g855cxz8mgnb490s7j1ksd300i5xgjsp")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'update-constraints
- (lambda _
- (substitute* "tree-diff.cabal"
- (("trifecta >=1\\.7\\.1\\.1 && <1\\.8")
- "trifecta >=1.7.1.1 && <=2")))))))
(inputs
`(("ghc-aeson" ,ghc-aeson)
("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
("ghc-ansi-terminal" ,ghc-ansi-terminal)
("ghc-base-compat" ,ghc-base-compat)
- ("ghc-generics-sop" ,ghc-generics-sop)
+ ("ghc-bytestring-builder" ,ghc-bytestring-builder)
("ghc-hashable" ,ghc-hashable)
- ("ghc-memotrie" ,ghc-memotrie)
("ghc-parsers" ,ghc-parsers)
("ghc-quickcheck" ,ghc-quickcheck)
("ghc-scientific" ,ghc-scientific)