aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm50
1 files changed, 29 insertions, 21 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index dc3001535a..10d546b918 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2023 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2023 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -70,6 +71,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-build)
+ #:use-module (gnu packages golang-xyz)
#:use-module (gnu packages graphics)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -1294,29 +1296,35 @@ on your file system and offers to remove it. @command{rmlint} can find:
(define-public lf
(package
(name "lf")
- ;; When updating, remove go-github-com-gdamore-tcell-v2-2.3 from golang.scm.
- (version "27")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gokcehan/lf")
- (commit (string-append "r" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1piym8za0iw2s8yryh39y072f90mzisv89ffvn1jzb71f71mbfqa"))))
+ (version "31")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gokcehan/lf")
+ (commit (string-append "r" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03icsf4c3j7295s1d8s6srz5gf09a3lghgw3zfcd86p03zhkzsaf"))))
(build-system go-build-system)
- (native-inputs
- (list go-github-com-mattn-go-runewidth go-golang-org-x-term
- go-gopkg-in-djherbis-times-v1 go-github-com-gdamore-tcell-v2-2.3))
(arguments
- `(#:import-path "github.com/gokcehan/lf"))
+ (list
+ #:go go-1.18
+ #:install-source? #f
+ #:import-path "github.com/gokcehan/lf"))
+ (native-inputs
+ (list go-github-com-djherbis-times
+ go-github-com-gdamore-tcell-v2
+ go-github-com-mattn-go-runewidth
+ go-golang-org-x-term
+ go-gopkg-in-djherbis-times-v1))
(home-page "https://github.com/gokcehan/lf")
(synopsis "Console file browser similar to Ranger")
- (description "lf (as in \"list files\") is a terminal file manager
-written in Go. It is heavily inspired by ranger with some missing and
-extra features. Some of the missing features are deliberately omitted
-since they are better handled by external tools.")
+ (description
+ "@code{lf} (as in \"list files\") is a terminal file manager written in
+Go. It is heavily inspired by @code{ranger} with some missing and extra
+features. Some of the missing features are deliberately omitted since they
+are better handled by external tools.")
(license license:expat)))
(define-public xfe
@@ -1656,7 +1664,7 @@ gone and to help you to clean it up.")
(define-public nwipe
(package
(name "nwipe")
- (version "0.35")
+ (version "0.36")
(source
(origin
(method git-fetch)
@@ -1665,7 +1673,7 @@ gone and to help you to clean it up.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1bj20y52qzz2ja56yf1pxqjg3lsda35c2k5hcj3lqm69jpsla2wq"))))
+ (base32 "075zwakv3lva46v6wab00l5x7bs2k73mzzhwlbvm839r8a6gm0dh"))))
(build-system gnu-build-system)
(arguments
(list #:phases