aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 2591d339d6..882170a8cb 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -43,10 +43,12 @@
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages c)
#:use-module (gnu packages check)
#:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages gcc)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libunwind)
@@ -732,6 +734,42 @@ of C++14 components that complements @code{std} and Boost.")
(supported-systems '("aarch64-linux" "x86_64-linux"))
(license license:asl2.0)))
+(define-public aws-sdk-cpp
+ (package
+ (name "aws-sdk-cpp")
+ (version "1.8.102")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/aws-sdk-cpp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1w8x2vakg5ngjyyg08n4g3dqy8wqnz0k3gkrlqrh460s2pvdivba"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(;; Tests are run during the build phase.
+ #:tests? #f
+ #:configure-flags
+ '("-DBUILD_SHARED_LIBS=OFF"
+ "-DBUILD_DEPS=OFF")))
+ (propagated-inputs
+ `(("aws-c-common" ,aws-c-common)
+ ("aws-c-event-stream" ,aws-c-event-stream)))
+ (inputs
+ `(("aws-checksums" ,aws-checksums)
+ ("curl" ,curl)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (synopsis "Amazon Web Services SDK for C++")
+ (description
+ "The AWS SDK for C++ provides a C++11 interface to the @acronym{AWS,Amazon
+Web Services} API. AWS provides on-demand computing infrastructure and software
+services including database, analytic, and machine learning technologies.")
+ (home-page "https://github.com/aws/aws-sdk-cpp")
+ (license license:asl2.0)))
+
(define-public libexpected
(package
(name "libexpected")