aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f6410c3ca4..67f24a6170 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13699,3 +13699,27 @@ are highly customizable. Currently, it is possible to plot: bigwig, bed (many
options), bedgraph, links (represented as arcs), and Hi-C matrices.
pyGenomeTracks can make plots with or without Hi-C data.")
(license license:gpl3+)))
+
+(define-public python-hic2cool
+ (package
+ (name "python-hic2cool")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hic2cool" version))
+ (sha256
+ (base32
+ "0xy6mhfns2lzib1kcr6419jjp6pmh0qx8z8na55lmiwn0ds8q9cl"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; no tests included
+ (propagated-inputs
+ `(("python-cooler" ,python-cooler)))
+ (home-page "https://github.com/4dn-dcic/hic2cool")
+ (synopsis "Converter for .hic and .cool files")
+ (description
+ "This package provides a converter between @code{.hic} files (from
+juicer) and single-resolution or multi-resolution @code{.cool} files (for
+cooler). Both @code{hic} and @code{cool} files describe Hi-C contact
+matrices.")
+ (license license:expat)))