aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm59
1 files changed, 28 insertions, 31 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 9ef0ee7f09..9884f58fc3 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -147,7 +147,7 @@ spying and/or modification by the server.")
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'autoreconf
- (lambda _ (zero? (system* "autoreconf" "-vfi")))))))
+ (lambda _ (invoke "autoreconf" "-vfi"))))))
(synopsis "File verification and repair tools")
(description "Par2cmdline uses Reed-Solomon error-correcting codes to
generate and verify PAR2 recovery files. These files can be distributed
@@ -420,7 +420,7 @@ rdiff-backup is easy to use and settings have sensible defaults.")
"t/backup_exec/conf/backup_exec.conf")
(("/bin/true") (which "true"))
(("/bin/false") (which "false")))
- (zero? (system* "make" "test")))))))
+ (invoke "make" "test"))))))
(inputs
`(("perl" ,perl)
("rsync" ,rsync)))
@@ -523,25 +523,24 @@ detection, and lossless compression.")
;; The tests should be run in an empty directory.
(mkdir-p "tests")
(with-directory-excursion "tests"
- (zero?
- (system* "py.test" "-v" "--pyargs" "borg.testsuite" "-k"
- (string-append
- ;; These tests need to write to '/var'.
- "not test_get_cache_dir "
- "and not test_get_config_dir "
- "and not test_get_keys_dir "
- "and not test_get_security_dir "
- ;; These tests assume there is a root user in
- ;; '/etc/passwd'.
- "and not test_access_acl "
- "and not test_default_acl "
- "and not test_non_ascii_acl "
- ;; This test needs the unpackaged pytest-benchmark.
- "and not benchmark "
- ;; These tests assume the kernel supports FUSE.
- "and not test_fuse "
- "and not test_fuse_allow_damaged_files "
- "and not test_mount_hardlinks"))))))
+ (invoke "py.test" "-v" "--pyargs" "borg.testsuite" "-k"
+ (string-append
+ ;; These tests need to write to '/var'.
+ "not test_get_cache_dir "
+ "and not test_get_config_dir "
+ "and not test_get_keys_dir "
+ "and not test_get_security_dir "
+ ;; These tests assume there is a root user in
+ ;; '/etc/passwd'.
+ "and not test_access_acl "
+ "and not test_default_acl "
+ "and not test_non_ascii_acl "
+ ;; This test needs the unpackaged pytest-benchmark.
+ "and not benchmark "
+ ;; These tests assume the kernel supports FUSE.
+ "and not test_fuse "
+ "and not test_fuse_allow_damaged_files "
+ "and not test_mount_hardlinks")))))
(add-after 'install 'install-doc
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -552,11 +551,9 @@ detection, and lossless compression.")
"docs/misc/internals-picture.txt"
"docs/misc/prune-example.txt"))
(add-installed-pythonpath inputs outputs)
- (and
- (zero? (system* "python3" "setup.py" "build_man"))
- (begin
- (copy-recursively "docs/man" man)
- #t))))))))
+ (invoke "python3" "setup.py" "build_man")
+ (copy-recursively "docs/man" man)
+ #t))))))
(native-inputs
`(("python-cython" ,python-cython)
("python-setuptools-scm" ,python-setuptools-scm)
@@ -686,17 +683,17 @@ NTFS volumes using @code{ntfs-3g}, preserving NTFS-specific attributes.")
(replace 'check
(lambda _
(substitute* "obnamlib/vfs_local_tests.py"
- ;; Check for the nobody user instead of root
+ ;; Check for the nobody user instead of root.
(("self.fs.get_username\\(0\\), 'root'")
"self.fs.get_username(65534), 'nobody'")
- ;; Disable tests checking for root group
+ ;; Disable tests checking for root group.
(("self.fs.get_groupname\\(0\\)") "'root'"))
(substitute* "obnamlib/vfs_local.py"
- ;; Don't cover get_groupname function
+ ;; Don't cover get_groupname function.
(("def get_groupname\\(self, gid\\):")
"def get_groupname(self, gid): # pragma: no cover"))
- ;; Can't run network tests
- (zero? (system* "./check" "--unit-tests")))))))
+ ;; Can't run network tests.
+ (invoke "./check" "--unit-tests"))))))
(inputs
`(("python2-cliapp" ,python2-cliapp)
("python2-larch" ,python2-larch)