aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6be7716956..b777eef02c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5091,3 +5091,28 @@ JSON gem (with C-extensions), the pure-Ruby JSON gem, NSJSONSerialization,
gson.rb, JrJackson, and OkJson.")
(home-page "https://github.com/intridea/multi_json")
(license license:expat)))
+
+(define-public ruby-cucumber-wire
+ (package
+ (name "ruby-cucumber-wire")
+ (version "0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "cucumber-wire" version))
+ (sha256
+ (base32
+ "09ymvqb0sbw2if1nxg8rcj33sf0va88ancq5nmp8g01dfwzwma2f"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; This is a small dependency of ruby-cucumber, and requires cucumber
+ ;; in general (e.g. the require 'cucumber/step_argument' in
+ ;; lib/cucumber/wire/protocol/requets.rb), including for the tests.
+ #:tests? #t
+ #:test-target "spec"))
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (synopsis "Wire protocol for Cucumber")
+ (description "Dependency of ruby-cucumber")
+ (home-page "https://github.com/cucumber/cucumber-ruby-wire")
+ (license license:expat)))