aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 68395c42fe..f2922ecfc7 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -311,6 +311,36 @@ announcement.")
(home-page "https://www.zenspider.com/projects/hoe.html")
(license license:expat)))
+(define-public ruby-hpricot
+ (package
+ (name "ruby-hpricot")
+ (version "0.8.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "hpricot" version))
+ (sha256
+ (base32
+ "1jn8x9ch79gqmnzgyz78kppavjh5lqx0y0r6frykga2b86rz9s6z"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-Rakefile
+ (lambda _
+ (substitute* "Rakefile"
+ (("REV = .*") "REV = '0'\n"))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis "Swift, liberal HTML parser with a fantastic library")
+ (description
+ "a swift, liberal HTML parser with a fantastic library")
+ (home-page
+ "http://code.whytheluckystiff.net/hpricot/")
+ (license #f)))
+
(define-public ruby-raabro
(package
(name "ruby-raabro")