aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 426b1f6179..26f5f77496 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8120,3 +8120,28 @@ but it can function as a stand-alone templating engine.")
(home-page
"http://github.com/brianmario/bzip2-ruby")
(license #f))))
+
+(define-public ruby-sass-spec
+ ;; There is no gem published so we package directly from the git repository.
+ (let ((commit "ac3d4160c19543273a8a515b0ec00014e311f329"))
+ (package
+ (name "ruby-sass-spec")
+ (version (string-append "0.8.3-1." (string-take commit 8)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sass/sass-spec.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0hmi1blvysf6388hmivn9idsn1s7hgi3yma3vzwdcaqjyhjbhsca"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #t)) ; There are no tests, but this is to stop people using
+ ; this gem as it does not install correctly.
+ (synopsis "")
+ (description
+ "")
+ (home-page "")
+ (license license:expat)))) ;?