aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index bdb3b79b6d..59a293333d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5862,3 +5862,31 @@ will probably be an issue and hence this gem.")
"Hashie is a collection of classes and mixins that make hashes more powerful.")
(home-page "https://github.com/intridea/hashie")
(license license:expat)))
+
+(define-public ruby-rspec-pending-for
+ (package
+ (name "ruby-rspec-pending-for")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rspec-pending_for" version))
+ (sha256
+ (base32
+ "0f9sj7v3j14fvd631smxr04l53pk8dqwn9ybqkjdqmzvcv73b5n6"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "spec"))
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (propagated-inputs
+ `(("ruby-rspec-core" ,ruby-rspec-core)
+ ("ruby-ruby-engine" ,ruby-ruby-engine)
+ ("ruby_version" ,ruby_version)))
+ (synopsis
+ "Mark specs pending or skipped for specific Ruby engine (e.g. MRI or JRuby) / version combinations")
+ (description
+ "Mark specs pending or skipped for specific Ruby engine (e.g. MRI or JRuby) / version combinations")
+ (home-page
+ "https://github.com/pboling/rspec-pending_for")
+ (license #f)))