aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/zwave.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/zwave.scm b/gnu/packages/zwave.scm
index 3e99bd7687..a30199ec02 100644
--- a/gnu/packages/zwave.scm
+++ b/gnu/packages/zwave.scm
@@ -112,6 +112,11 @@ knowledge of the Z-Wave protocol.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'build 'patch-compiler
+ (lambda _
+ (substitute* "binding.gyp"
+ (("std=c\\+\\+11")
+ "std=c++17"))))
(replace 'build
;; For some reason, `npm install` doesn't build
;; the addon automatically, so we do it explicitly here.