aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/commencement.scm5
-rw-r--r--gnu/packages/gcc.scm5
2 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 25e96b1aa6..fc1c508b38 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2452,7 +2452,10 @@ exec " gcc "/bin/" program
,@(alist-delete "libc" (%boot0-inputs))))
;; No need for the native-inputs to build the documentation at this stage.
- (native-inputs `())))
+ (native-inputs
+ (if (target-hurd?)
+ `(("hurd-patch" ,(search-patch "gcc-11-libstdc++-hurd-libpthread.patch")))
+ '()))))
(define perl-boot0
(package
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 9ae6f77b37..fade5bb64b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -719,10 +719,9 @@ It also includes runtime support libraries for these languages.")
(if (target-hurd?)
`(modify-phases ,phases
(add-after 'unpack 'patch-hurd-libpthread
- (lambda (#:key inputs)
+ (lambda _
(invoke "patch" "--force" "-p1" "-i"
- (assoc-ref inputs "hurd-patch")
- patch))))
+ (assoc-ref %build-inputs "hurd-patch")))))
phases))))
(properties
`((compiler-cpu-architectures