aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c9c6ec7ef2..4c75eb285d 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -676,19 +676,19 @@ GTK icon cache for instance.")))
(search-patches "nix-dont-build-html-doc.diff"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--sysconfdir=/etc" "--enable-gc")
- #:phases
- (modify-phases %standard-phases
- (replace 'install
- ;; Don't try & fail to create subdirectories in /etc, but keep them
- ;; in the output as examples.
- (lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (etc (string-append out "/etc")))
- (apply invoke "make" "install"
- (string-append "sysconfdir=" etc)
- (string-append "profiledir=" etc "/profile.d")
- make-flags)))))))
+ (list
+ #:configure-flags #~(list "--sysconfdir=/etc" "--enable-gc")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ ;; Don't try & fail to create subdirectories in /etc, but keep them
+ ;; in the output as examples.
+ (lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
+ (let ((etc (string-append #$output "/etc")))
+ (apply invoke "make" "install"
+ (string-append "sysconfdir=" etc)
+ (string-append "profiledir=" etc "/profile.d")
+ make-flags)))))))
(native-inputs
(list autoconf
autoconf-archive