aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3406161c7c..16f4e2d530 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1296,7 +1296,16 @@ interactive environment for the functional language Haskell.")
(replace 'fix-cc-reference
(lambda _
(substitute* "utils/hsc2hs/src/Common.hs"
- (("\"cc\"") "\"gcc\""))))))
+ (("\"cc\"") "\"gcc\""))))
+ ;; FIXME: Remove i686-specific match on the next rebuild cycle.
+ #$@(match (%current-system)
+ ("i686-linux"
+ #~((add-after 'skip-more-tests 'skip-T21694-i686
+ (lambda _
+ (substitute* '("testsuite/tests/simplCore/should_compile/all.T")
+ (("^test\\('T21694', \\[ " all)
+ (string-append all "when(arch('i386'), skip), ")))))))
+ (_ #~()))))
;; Increase verbosity, so running the test suite does not time out on CI.
((#:make-flags make-flags ''())
#~(cons "VERBOSE=4" #$make-flags))))