summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-12-16 13:20:49 +0100
committerMathieu Lirzin <mthl@gnu.org>2016-12-16 13:20:49 +0100
commite9e1ce8e14ffdbd8ddddaacc93e0e71d0c29a992 (patch)
tree856b9a457bc63667efbfb6f962be957fdd2f79ae
parent5dc1bf40e96ee40f9e786ffeafc3eb895b4e8e74 (diff)
downloadcuirass-e9e1ce8e14ffdbd8ddddaacc93e0e71d0c29a992.tar
cuirass-e9e1ce8e14ffdbd8ddddaacc93e0e71d0c29a992.tar.gz
maint: Move examples from 'tests' to 'examples' directory.
* examples/gnu-system.scm: Moved from 'tests' directory. * examples/guix-jobs.scm: Likewise. * examples/guix-track-git.scm: Likewise. * examples/hello-git.scm: Likewise. * examples/hello-singleton.scm: Likewise. * examples/hello-subset.scm: Likewise. * Makefile.am (EXTRA_DIST): Adapt. * README <Example>: Likewise.
-rw-r--r--Makefile.am8
-rw-r--r--README4
-rw-r--r--examples/gnu-system.scm (renamed from tests/gnu-system.scm)0
-rw-r--r--examples/guix-jobs.scm (renamed from tests/guix-jobs.scm)0
-rw-r--r--examples/guix-track-git.scm (renamed from tests/guix-track-git.scm)0
-rw-r--r--examples/hello-git.scm (renamed from tests/hello-git.scm)0
-rw-r--r--examples/hello-singleton.scm (renamed from tests/hello-singleton.scm)0
-rw-r--r--examples/hello-subset.scm (renamed from tests/hello-subset.scm)0
8 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index d198e01..99d2b4b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -113,10 +113,10 @@ EXTRA_DIST = \
bin/evaluate.in \
bootstrap \
src/cuirass/config.scm.in \
- tests/gnu-system.scm \
- tests/guix-jobs.scm \
- tests/hello-singleton.scm \
- tests/hello-subset.scm \
+ examples/gnu-system.scm \
+ examples/guix-jobs.scm \
+ examples/hello-singleton.scm \
+ examples/hello-subset.scm \
$(TESTS)
MOSTLYCLEANFILES = $(bin_SCRIPTS) src/cuirass/config.scm
diff --git a/README b/README
index 41cca7c..a0b3159 100644
--- a/README
+++ b/README
@@ -26,9 +26,9 @@ Example
A quick way to manually test Cuirass is to execute:
- ./pre-inst-env cuirass --specifications=tests/hello-singleton.scm --database=test.db
+ ./pre-inst-env cuirass --specifications=examples/hello-singleton.scm --database=test.db
-This will read the file "tests/hello-singleton.scm" which contains a list of
+This will read the file "examples/hello-singleton.scm" which contains a list of
specifications and add them to the database "test.db" which is created if it
doesn't already exist.
diff --git a/tests/gnu-system.scm b/examples/gnu-system.scm
index 8e29fec..8e29fec 100644
--- a/tests/gnu-system.scm
+++ b/examples/gnu-system.scm
diff --git a/tests/guix-jobs.scm b/examples/guix-jobs.scm
index 862cff7..862cff7 100644
--- a/tests/guix-jobs.scm
+++ b/examples/guix-jobs.scm
diff --git a/tests/guix-track-git.scm b/examples/guix-track-git.scm
index 10a3d48..10a3d48 100644
--- a/tests/guix-track-git.scm
+++ b/examples/guix-track-git.scm
diff --git a/tests/hello-git.scm b/examples/hello-git.scm
index f6df99c..f6df99c 100644
--- a/tests/hello-git.scm
+++ b/examples/hello-git.scm
diff --git a/tests/hello-singleton.scm b/examples/hello-singleton.scm
index 5ff2e82..5ff2e82 100644
--- a/tests/hello-singleton.scm
+++ b/examples/hello-singleton.scm
diff --git a/tests/hello-subset.scm b/examples/hello-subset.scm
index 60764fc..60764fc 100644
--- a/tests/hello-subset.scm
+++ b/examples/hello-subset.scm