aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-15 16:13:36 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-26 18:19:34 +0100
commit1d84d7bf6052c0c80bd212d4524876576e9817d4 (patch)
tree469a7694b9ebacf8949758d79febebc7c399233d /tests
parentcb723be5b98a57ae4f909022d1ce2b5d3bcdaabf (diff)
downloadguix-1d84d7bf6052c0c80bd212d4524876576e9817d4.tar
guix-1d84d7bf6052c0c80bd212d4524876576e9817d4.tar.gz
build: Require Guile >= 2.0.13.
* README, configure.ac, doc/guix.texi (Requirements): Increase minimum Guile version from 2.0.9 to 2.0.13. * config-daemon.ac: Remove use of 'GUIX_CHECK_UNBUFFERED_CBIP'. * m4/guix.m4 (GUIX_CHECK_UNBUFFERED_CBIP): Remove. * guix/build/download.scm (current-http-proxy): Remove. * guix/build/syscalls.scm (%libc-errno-pointer, errno): Remove. (syscall->procedure): Use #:return-errno unconditionally. * guix/hash.scm (open-sha256-input-port)[unbuffered]: Remove outdated comment. * guix/http-client.scm (when-guile<=2.0.5-or-otherwise-broken): Remove. <top level>: Remove 'when-guile<=2.0.5-or-otherwise-broken' block. * guix/scripts/substitute.scm (fetch): Remove 'guile-version>?' conditional. * tests/hash.scm (supports-unbuffered-cbip?): Remove. <top level>: Remove 'test-skip' call.
Diffstat (limited to 'tests')
-rw-r--r--tests/hash.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/tests/hash.scm b/tests/hash.scm
index b189e435c8..b4cf2b61d6 100644
--- a/tests/hash.scm
+++ b/tests/hash.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,13 +37,6 @@
(base16-string->bytevector
"b94d27b9934d3e08a52e52d7da7dabfac484efe37a5380ee9088f7ace2efcde9"))
-(define (supports-unbuffered-cbip?)
- "Return #t if unbuffered custom binary input ports (CBIPs) are supported.
-In Guile <= 2.0.9, CBIPs were always fully buffered, so the
-'open-sha256-input-port' does not work there."
- (false-if-exception
- (setvbuf (make-custom-binary-input-port "foo" pk #f #f #f) _IONBF)))
-
(test-begin "hash")
@@ -77,8 +70,6 @@ In Guile <= 2.0.9, CBIPs were always fully buffered, so the
(equal? (sha256 contents)
(call-with-input-file file port-sha256))))
-(test-skip (if (supports-unbuffered-cbip?) 0 4))
-
(test-equal "open-sha256-input-port, empty"
`("" ,%empty-sha256)
(let-values (((port get)