aboutsummaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-03-19 22:06:22 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-03-22 20:19:44 +0200
commit3a7597e4147235781d43ba9cef7a52ced9ea5e7a (patch)
tree501f12b0eb5de9e0fe35ed9e6ea19fd0ef3cd49a /guix
parenta53f4311a1e9bf2f1e863a5d49ae2316b96fe469 (diff)
downloadguix-3a7597e4147235781d43ba9cef7a52ced9ea5e7a.tar
guix-3a7597e4147235781d43ba9cef7a52ced9ea5e7a.tar.gz
build-system/meson: Use 'target-arm32?' for armhf-linux case.
* guix/build-system/meson.scm (lower, meson-build): Replace armhf-linux detection with 'target-arm32?' macro.
Diffstat (limited to 'guix')
-rw-r--r--guix/build-system/meson.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/guix/build-system/meson.scm b/guix/build-system/meson.scm
index 529a2b8b0f..88a7b58286 100644
--- a/guix/build-system/meson.scm
+++ b/guix/build-system/meson.scm
@@ -86,8 +86,7 @@
;; to avoid superfluous entries in RUNPATH as described
;; in <https://bugs.gnu.org/28444#46>, so armhf may now
;; have different runtime dependencies from other arches.
- ,@(if (not (string-prefix? "arm" (or (%current-target-system)
- (%current-system))))
+ ,@(if (not (target-arm32?))
`(("patchelf" ,(default-patchelf)))
'())
,@native-inputs))
@@ -148,8 +147,7 @@ has a 'meson.build' file."
#:search-paths ',(map search-path-specification->sexp
search-paths)
#:phases
- (if (string-prefix? "arm" ,(or (%current-target-system)
- (%current-system)))
+ (if (target-arm32?)
(modify-phases build-phases (delete 'fix-runpath))
build-phases)
#:configure-flags ,configure-flags