aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-04-20 11:47:50 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-20 11:47:50 +0100
commitda77ea23daa0bfa4a73290dff99b22d6825ff80b (patch)
tree748d24e62b93c8ab8f999d6415d9f65c3d317da2 /gnu/packages/python-check.scm
parent4eeb6922449285f9bce615f6e4ffe4375fa0233f (diff)
parent949f97f7f98ac74306b9de79c93790337d804e32 (diff)
downloadguix-da77ea23daa0bfa4a73290dff99b22d6825ff80b.tar
guix-da77ea23daa0bfa4a73290dff99b22d6825ff80b.tar.gz
Merge commit '949f97f7f9' into core-update-new-2chris-core-updates-no-duplicates-attempt
Change-Id: Ibbd851541da42cc052ba58195fee033daadd57e5 Conflicts: gnu/local.mk gnu/packages/bioinformatics.scm gnu/packages/dictionaries.scm gnu/packages/display-managers.scm gnu/packages/engineering.scm gnu/packages/geo.scm gnu/packages/gl.scm gnu/packages/glib.scm gnu/packages/gnome-xyz.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/llvm.scm gnu/packages/mail.scm gnu/packages/patches/eudev-rules-directory.patch gnu/packages/plotutils.scm gnu/packages/sdl.scm gnu/packages/syndication.scm
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm57
1 files changed, 44 insertions, 13 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 51a38bbcbe..b39709d960 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -545,20 +546,25 @@ astropy related packages.")
(define-public python-pytest-arraydiff
(package
(name "python-pytest-arraydiff")
- (version "0.5.0")
+ (version "0.6.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-arraydiff" version))
(sha256
- (base32 "1livzfbi7ag17hskd5845dh1kdir24f7jrbw8y2s1pyhzyz4jhbi"))))
- (build-system python-build-system)
+ (base32 "1pk7v96rkypx4ld59f6p8fh5bq371ka8g7bh4h7n4df91x2v2dr9"))))
+ (build-system pyproject-build-system)
(arguments
- ;; Tests require python-astropy, which itself requires this package.
- ;; Disable tests to avoid the circular dependency problem.
- '(#:tests? #f))
+ (list
+ #:test-flags
+ #~(list "-k" (string-append
+ ;; Disable tests requiring python-astropy, to break cycle.
+ "not test_succeeds_func_fits_hdu"
+ " and not test_fails"
+ " and not test_generate"
+ " and not test_default_format"))))
(native-inputs
- (list python-pytest python-setuptools-scm)) ; for sanity-check
+ (list python-pytest python-setuptools-scm))
(propagated-inputs
(list python-numpy))
(home-page "https://github.com/astropy/pytest-arraydiff")
@@ -604,26 +610,29 @@ running the tests.")
(define-public python-pytest-doctestplus
(package
(name "python-pytest-doctestplus")
- (version "1.0.0")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-doctestplus" version))
(sha256
- (base32 "17ylfnrcvvp6sd13bfj40jl40paqmjsbywysszb3xqgdr86l8l7n"))))
+ (base32 "0cmrkgpib869kpy8h8hfkg20w16lakkmbkw8cxdywpmf5wx7dbf5"))))
(build-system pyproject-build-system)
(arguments
(list #:test-flags
#~(list "-k" (string-append
+ ;; Tests requiring network access.
"not test_remote_data_url"
" and not test_remote_data_float_cmp"
" and not test_remote_data_ignore_whitespace"
" and not test_remote_data_ellipsis"
" and not test_remote_data_requires"
- " and not test_remote_data_ignore_warnings"))))
+ " and not test_remote_data_ignore_warnings"
+ ;; Requiring git available.
+ " and not test_generate_diff_basic"))))
(native-inputs
(list python-numpy python-pytest python-setuptools-scm))
- (home-page "https://github.com/astropy/pytest-doctestplus")
+ (home-page "https://github.com/scientific-python/pytest-doctestplus")
(synopsis "Pytest plugin with advanced doctest features")
(description
"This package contains a plugin for the Pytest framework that provides
@@ -660,13 +669,13 @@ for interactively selecting and running Pytest tests.")
(define-public python-pytest-filter-subpackage
(package
(name "python-pytest-filter-subpackage")
- (version "0.1.2")
+ (version "0.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-filter-subpackage" version))
(sha256
- (base32 "10hpl3f7g2bm29lakmp8492b7lr0dp90khfni12m4gl02xks7bhz"))))
+ (base32 "0mmgg2n8qk6s2kprycjl70lxcpm43dkapplmkf32i0ai6qdqyiiz"))))
(build-system pyproject-build-system)
(native-inputs
(list python-pytest
@@ -1093,6 +1102,28 @@ of the project to ensure it renders properly.")
simpler.")
(license license:expat)))
+(define-public python-pytest-testmon
+ (package
+ (name "python-pytest-testmon")
+ (version "2.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tarpas/pytest-testmon")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01qhbkb3n8c5c4id94w6b06q9wb7b6a33mqwyrkdfzk5pzv1gcyd"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #false)) ;there are none
+ (native-inputs (list python-coverage python-pytest))
+ (home-page "https://github.com/tarpas/pytest-testmon")
+ (synopsis "Selects tests affected by changed files and methods")
+ (description
+ "This plug-in auto-selects and reruns tests impacted by recent changes.")
+ (license license:expat)))
+
(define-public python-pytest-trio
(package
(name "python-pytest-trio")