aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-04-18 00:09:55 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-25 17:20:19 +0200
commit74038cf66e3a8cdcd9d97a81d9176c3cdefdaaf7 (patch)
treef20a69219e3c5ba57769b25781a1e8d5227e1706 /gnu/packages/gcc.scm
parent7f0fbd046386cef3565cc79477856c72e0496377 (diff)
downloadguix-74038cf66e3a8cdcd9d97a81d9176c3cdefdaaf7.tar
guix-74038cf66e3a8cdcd9d97a81d9176c3cdefdaaf7.tar.gz
gnu: gcc: Do not build gcov on MinGW.
* gnu/packages/gcc.scm (gcc-configure-flags-for-triplet): Disable gcov when targetting mingw. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index b7d15d0730..e3ce0069f0 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -88,6 +88,11 @@ where the OS part is overloaded to denote a specific ABI---into GCC
(string-prefix? "powerpc-" target))
'("--with-long-double-128"))
+ ;; GCC 11.3.0's <libgcov.h> includes <sys/mman.h>, which MinGW lacks:
+ ;; <https://bugs.gentoo.org/show_bug.cgi?id=843989>.
+ ((target-mingw? target)
+ '("--disable-gcov"))
+
(else
;; TODO: Add `arm.*-gnueabi', etc.
'())))