aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-08-05 12:12:21 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-08-19 04:38:15 +0200
commitd79013f66a98dca24e11193c43e78364043d0c16 (patch)
tree28659062c9571fff42f6979874e174b749846945 /Makefile.am
parente121be1e15b79ed179b5618a7b47d94b6aa7024d (diff)
downloadguix-d79013f66a98dca24e11193c43e78364043d0c16.tar
guix-d79013f66a98dca24e11193c43e78364043d0c16.tar.gz
maint: Create an ISO9660 installation image in the 'release' target.
* Makefile.am (GUIXSD_IMAGE_BASE): Adapt target file name. (release): Use file-system-type iso9660. * doc/guix.texi: Document installation from DVD.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 91a9113d22..9ba4ccba78 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -577,7 +577,7 @@ GUIXSD_SUPPORTED_SYSTEMS ?= x86_64-linux i686-linux
GUIXSD_VM_SYSTEMS ?= x86_64-linux
# Prefix of the GuixSD installation image file name.
-GUIXSD_IMAGE_BASE = guixsd-usb-install-$(PACKAGE_VERSION)
+GUIXSD_IMAGE_BASE = guixsd-install-$(PACKAGE_VERSION)
# Prefix of the GuixSD VM image file name.
GUIXSD_VM_IMAGE_BASE = guixsd-vm-image-$(PACKAGE_VERSION)
@@ -628,6 +628,7 @@ release: dist
for system in $(GUIXSD_SUPPORTED_SYSTEMS) ; do \
image=`$(top_builddir)/pre-inst-env \
guix system disk-image \
+ --file-system-type=iso9660 \
--system=$$system \
gnu/system/install.scm` ; \
if [ ! -f "$$image" ] ; then \