aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:40:40 +0100
committerChristopher Baines <mail@cbaines.net>2018-07-16 07:38:06 +0100
commitdeb2e8fbd6e62f66a8f66e073a250df31414dca1 (patch)
tree44518f645d95c4c3bbb2c9cafec3b07ae9344142
parent45b81b32ad2eb57357ff1d9437ddf5c200e50511 (diff)
downloadguix-deb2e8fbd6e62f66a8f66e073a250df31414dca1.tar
guix-deb2e8fbd6e62f66a8f66e073a250df31414dca1.tar.gz
gnu: Add ruby-multi-json.
-rw-r--r--gnu/packages/ruby.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1968cf4700..6be7716956 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5052,3 +5052,42 @@ replacement.")
decoding of JSON is implemented as a C extension to Ruby.")
(home-page "http://www.ohler.com/oj")
(license license:expat)))
+
+(define-public ruby-multi-json
+ (package
+ (name "ruby-multi-json")
+ (version "1.13.1")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Tests are not distributed at rubygems.org so download from GitHub
+ ;; instead.
+ (uri (string-append "https://github.com/intridea/multi_json/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1s64xqvrnrxmb59v6b2kchnisawg5ai9ky1w60dy6z6ws9la1xv4"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-signing-key-reference
+ (lambda _
+ (substitute* "multi_json.gemspec"
+ ((".*spec.signing_key.*") ""))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-yard" ,ruby-yard)
+ ("ruby-json-pure" ,ruby-json-pure)
+ ("ruby-oj" ,ruby-oj)
+ ("ruby-yajl-ruby" ,ruby-yajl-ruby)))
+ (synopsis "Common Ruby interface to multiple JSON libraries")
+ (description
+ "A common interface to multiple JSON libraries, including Oj, Yajl, the
+JSON gem (with C-extensions), the pure-Ruby JSON gem, NSJSONSerialization,
+gson.rb, JrJackson, and OkJson.")
+ (home-page "https://github.com/intridea/multi_json")
+ (license license:expat)))