aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:57:45 +0100
committerChristopher Baines <mail@cbaines.net>2018-07-16 07:38:07 +0100
commitbc7735e5b624b1ed1f09a693eb6da72d77b10480 (patch)
tree96f5b012456d0f6028310ab4c6c403cf801e249e
parent2d52a8adff1bab73a583c42b066b4fffe54785db (diff)
downloadguix-bc7735e5b624b1ed1f09a693eb6da72d77b10480.tar
guix-bc7735e5b624b1ed1f09a693eb6da72d77b10480.tar.gz
gnu: Add ruby-ruby-progressbar.
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 38315757cd..e7faed5fcd 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5363,3 +5363,33 @@ adds support for IRIs and URI templates.")
(home-page
"https://github.com/sporkmonger/addressable")
(license license:asl2.0)))
+
+;; There is a separate gem called 'progressbar', so we name the package here
+;; 'ruby-ruby-progressbar'.
+(define-public ruby-ruby-progressbar
+ (package
+ (name "ruby-ruby-progressbar")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ruby-progressbar" version))
+ (sha256
+ (base32
+ "1qzc7s7r21bd7ah06kskajc2bjzkr9y0v5q48y0xwh2l55axgplm"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests require further dependencies such as 'rspectacular'.
+ (synopsis
+ "Ruby/ProgressBar is an extremely flexible text progress bar library for Ruby.
+The output can be customized with a flexible formatting system including:
+percentage, bars of various formats, elapsed time and estimated time remaining.
+")
+ (description
+ "Ruby/ProgressBar is an extremely flexible text progress bar library for Ruby.
+The output can be customized with a flexible formatting system including:
+percentage, bars of various formats, elapsed time and estimated time remaining.
+")
+ (home-page
+ "https://github.com/jfelchner/ruby-progressbar")
+ (license license:expat)))