aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-07-14 09:27:10 +0100
committerChristopher Baines <mail@cbaines.net>2018-07-16 07:38:06 +0100
commitbb1355d04c2e0946662a551a7a8bc8e1e645d662 (patch)
tree14bc6d81a9708ad3edf54c09a09f239a81f5fd9c
parent076a6e67efa19eba26bfcac08477812283100717 (diff)
downloadguix-bb1355d04c2e0946662a551a7a8bc8e1e645d662.tar
guix-bb1355d04c2e0946662a551a7a8bc8e1e645d662.tar.gz
gnu: Add ruby-cucumber-core-1.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b777eef02c..cabb6db9e9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3555,6 +3555,33 @@ and trust on your team.")
(home-page "https://cucumber.io/")
(license license:expat)))
+(define-public ruby-cucumber-core-1
+ (package
+ (name "ruby-cucumber-core")
+ (version "1.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "cucumber-core" version))
+ (sha256
+ (base32
+ "0qj2fsqvp94nggnikbnrfvnmzr1pl6ifmdsxj69kdw1kkab30jjr"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-gherkin" ,ruby-gherkin)))
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (arguments
+ '(#:tests? #f)) ; needs simplecov, among others
+ (synopsis "Core library for the Cucumber BDD app")
+ (description "Cucumber is a tool for running automated tests
+written in plain language. Because they're written in plain language,
+they can be read by anyone on your team. Because they can be read by
+anyone, you can use them to help improve communication, collaboration
+and trust on your team.")
+ (home-page "https://cucumber.io/")
+ (license license:expat)))
+
(define-public ruby-bio-logger
(package
(name "ruby-bio-logger")