aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-06-25 11:50:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-06-26 14:45:58 +0300
commita495998b79f34ebad89942f8827fc18283c0723c (patch)
tree31ef33ced8360462a2d06c4a92c0c3d7698ed95c
parent64b2efc12c7f0e22f71660b8486e712d5546d4cb (diff)
downloadguix-a495998b79f34ebad89942f8827fc18283c0723c.tar
guix-a495998b79f34ebad89942f8827fc18283c0723c.tar.gz
gnu: ant-bootstrap: Fix building on armhf-linux.
* gnu/packages/java.scm (ant-bootstrap)[arguments]: On armhf-linux add different flags to the 'bootstrap.sh' file.
-rw-r--r--gnu/packages/java.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 54bfd8cc3a..e7e34a2910 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -253,7 +253,10 @@ JNI.")
;; Without these JamVM options the build may freeze.
(substitute* "bootstrap.sh"
(("^\"\\$\\{JAVACMD\\}\" " m)
- (string-append m "-Xnocompact -Xnoinlining ")))
+ ,@(if (string-prefix? "armhf" (or (%current-system)
+ (%current-target-system)))
+ `((string-append m "-Xnocompact "))
+ `((string-append m "-Xnocompact -Xnoinlining ")))))
;; Disable tests because we are bootstrapping and thus don't have
;; any of the dependencies required to build and run the tests.