aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-15 22:39:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-15 22:59:26 +0300
commit1cd968e8549ab13a716e8b0c4a946276a2239eaa (patch)
tree1baea1be92474e0f04596cbcb39777559cf0e07f
parent22f003880cccc73903b63bbb0f6a74cc4907dce6 (diff)
downloadguix-1cd968e8549ab13a716e8b0c4a946276a2239eaa.tar
guix-1cd968e8549ab13a716e8b0c4a946276a2239eaa.tar.gz
gnu: openimageio: Don't use unstable tarball.
* gnu/packages/graphics.scm (openimageio)[source]: Download the source from a git repository.
-rw-r--r--gnu/packages/graphics.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 65f023a488..1b59ff3fc3 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017, 2018 Ben Woodcroft <donttrustben@gmail.com>
@@ -373,13 +373,14 @@ storage of the \"EXR\" file format for storing 16-bit floating-point images.")
(name "openimageio")
(version "1.7.19")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/OpenImageIO/oiio/"
- "archive/Release-" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenImageIO/oiio.git")
+ (commit (string-append "Release-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1qlmfhvl2wva4aifyiq7c4sdy61ddl7wykwvlpfys9p701xghvj7"))))
+ "0yxxy43l3lllw7maqg42dlkgqms2d4772sxzxk7kmxg4lnhsvndc"))))
(build-system cmake-build-system)
;; FIXME: To run all tests successfully, test image sets from multiple
;; third party sources have to be present. For details see