aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-15 21:49:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-15 22:59:25 +0300
commit080e11b48e6af05f6d051bfab6b4bd7830ef664c (patch)
tree04729d18fd97f2d69c1f67d2477127e753e0887b
parent4f963b6f29b850b1dcb1270cca3075417dc4962f (diff)
downloadguix-080e11b48e6af05f6d051bfab6b4bd7830ef664c.tar
guix-080e11b48e6af05f6d051bfab6b4bd7830ef664c.tar.gz
gnu: rust@1.25: Fix build on aarch64-linux.
* gnu/packages/rust.scm (rust@1.25)[arguments]: Replace inherited custom 'patch-aarch64-test phase. Make sure all phases return #t.
-rw-r--r--gnu/packages/rust.scm22
1 files changed, 18 insertions, 4 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 761f3966c9..28bffb44bb 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -554,14 +554,28 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
((#:phases phases)
`(modify-phases ,phases
(add-after 'patch-cargo-tests 'patch-cargo-index-update
- (lambda* _
+ (lambda _
(substitute* "src/tools/cargo/tests/generate-lockfile.rs"
;; This test wants to update the crate index.
- (("fn no_index_update") "#[ignore]\nfn no_index_update"))))
+ (("fn no_index_update") "#[ignore]\nfn no_index_update"))
+ #t))
(add-after 'configure 'enable-codegen-tests
- (lambda* _
+ (lambda _
(substitute* "config.toml"
- (("codegen-tests = false") ""))))
+ (("codegen-tests = false") ""))
+ #t))
+ (replace 'patch-aarch64-test
+ (lambda _
+ (substitute* "src/librustc_metadata/dynamic_lib.rs"
+ ;; This test is known to fail on aarch64 and powerpc64le:
+ ;; https://github.com/rust-lang/rust/issues/45410
+ (("fn test_loading_cosine") "#[ignore]\nfn test_loading_cosine"))
+ ;; This test fails on aarch64 with llvm@6.0:
+ ;; https://github.com/rust-lang/rust/issues/49807
+ ;; other possible solution:
+ ;; https://github.com/rust-lang/rust/pull/47688
+ (delete-file "src/test/debuginfo/by-value-self-argument-in-trait-impl.rs")
+ #t))
(delete 'ignore-glibc-2.27-incompatible-test))))))))
(define-public rust-1.26