aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:40:18 +0100
committerChristopher Baines <mail@cbaines.net>2018-07-16 07:38:06 +0100
commit076a6e67efa19eba26bfcac08477812283100717 (patch)
treef7cddc1436647f9eaf99e79dc248e30e3f606925
parentdeb2e8fbd6e62f66a8f66e073a250df31414dca1 (diff)
downloadguix-076a6e67efa19eba26bfcac08477812283100717.tar
guix-076a6e67efa19eba26bfcac08477812283100717.tar.gz
gnu: Add ruby-cucumber-wire.
* gnu/packages/ruby.scm (ruby-cucumber-wire): New variable.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6be7716956..b777eef02c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5091,3 +5091,28 @@ JSON gem (with C-extensions), the pure-Ruby JSON gem, NSJSONSerialization,
gson.rb, JrJackson, and OkJson.")
(home-page "https://github.com/intridea/multi_json")
(license license:expat)))
+
+(define-public ruby-cucumber-wire
+ (package
+ (name "ruby-cucumber-wire")
+ (version "0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "cucumber-wire" version))
+ (sha256
+ (base32
+ "09ymvqb0sbw2if1nxg8rcj33sf0va88ancq5nmp8g01dfwzwma2f"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; This is a small dependency of ruby-cucumber, and requires cucumber
+ ;; in general (e.g. the require 'cucumber/step_argument' in
+ ;; lib/cucumber/wire/protocol/requets.rb), including for the tests.
+ #:tests? #t
+ #:test-target "spec"))
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (synopsis "Wire protocol for Cucumber")
+ (description "Dependency of ruby-cucumber")
+ (home-page "https://github.com/cucumber/cucumber-ruby-wire")
+ (license license:expat)))