aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:00:15 +0100
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commitfac556a1e1e02d812ea3c80faf4a84cc8a10c7ef (patch)
tree19cd201ebf4b5c9ab7f1a1276452044207f42abf
parentaf35ac02b4f2945cb8d2f5c15901c620d44738eb (diff)
downloadguix-fac556a1e1e02d812ea3c80faf4a84cc8a10c7ef.tar
guix-fac556a1e1e02d812ea3c80faf4a84cc8a10c7ef.tar.gz
gnu: Add ruby-sass.
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index edcf92b87a..12d71cd1db 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7384,3 +7384,37 @@ but it can function as a stand-alone templating engine.")
"Sprockets is a Rack-based asset packaging system that concatenates and serves JavaScript, CoffeeScript, CSS, LESS, Sass, and SCSS.")
(home-page "https://github.com/rails/sprockets")
(license license:expat)))
+
+(define-public ruby-sass
+ (package
+ (name "ruby-sass")
+ (version "3.4.22")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "sass" version))
+ (sha256
+ (base32
+ "0dkj6v26fkg1g0majqswwmhxva7cd6p3psrhdlx93qal72dssywy"))))
+ (build-system ruby-build-system)
+ (arguments
+ ;; Cannot run sass-spec options because the sass-spec package does
+ ;; not work. TODO: Fix.
+ `(#:test-target "test:ruby"))
+ (native-inputs
+ `(("ruby-rubycop" ,ruby-rubocop)
+ ("ruby-ruby-progressbar" ,ruby-ruby-progressbar)))
+ (synopsis
+ " Sass makes CSS fun again. Sass is an extension of CSS, adding
+ nested rules, variables, mixins, selector inheritance, and more.
+ It's translated to well-formatted, standard CSS using the
+ command line tool or a web-framework plugin.
+")
+ (description
+ " Sass makes CSS fun again. Sass is an extension of CSS, adding
+ nested rules, variables, mixins, selector inheritance, and more.
+ It's translated to well-formatted, standard CSS using the
+ command line tool or a web-framework plugin.
+")
+ (home-page "http://sass-lang.com/")
+ (license license:expat)))