aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:51 +0000
committerChristopher Baines <mail@cbaines.net>2018-08-05 17:15:44 +0100
commitf3224e1be92814523ef03223be41fc21849e3712 (patch)
treed8e5796ac7d50f0a334177198f35db5f516bf1aa
parent408dbe33233c6243ff3cbea343910c54aca99da4 (diff)
downloadguix-f3224e1be92814523ef03223be41fc21849e3712.tar
guix-f3224e1be92814523ef03223be41fc21849e3712.tar.gz
gnu: Add ruby-warden.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 38ed7ed8b4..70c18b2dd3 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8452,3 +8452,25 @@ but it can function as a stand-alone templating engine.")
(home-page
"https://github.com/omniauth/omniauth")
(license license:expat)))
+
+(define-public ruby-warden
+ (package
+ (name "ruby-warden")
+ (version "1.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "warden" version))
+ (sha256
+ (base32
+ "0va966lhpylcwbqb9n151kkihx30agh0a57mwjwdxyanll4s1q12"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs `(("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "Rack middleware that provides authentication for rack applications")
+ (description
+ "Rack middleware that provides authentication for rack applications")
+ (home-page "http://github.com/hassox/warden")
+ (license license:expat)))